Arbitrary code execution in less-openui5
Key facts
- Attack vector
- Local
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.
Summary
less-openui5 is an npm package which enables building OpenUI5 themes with Less.js. In less-openui5 before version 0.10., when processing theming resources (i.e. `*.less` files) with less-openui5 that originate from an untrusted source, those resources might contain JavaScript code which will be executed in the context of the build process. While this is a feature of the Less.js library it is an unexpected behavior in the context of OpenUI5 and SAPUI5 development. Especially in the context of UI5 Tooling which relies on less-openui5. An attacker might create a library or theme-library containing a custom control or theme, hiding malicious JavaScript code in one of the .less files. Refer to the referenced GHSA-3crj-w4f5-gwh4 for examples. Starting with Less.js version 3.0.0, the Inline JavaScript feature is disabled by default. less-openui5 however currently uses a fork of Less.js v1.6.3. Note that disabling the Inline JavaScript feature in Less.js versions 1.x, still evaluates code has additional double codes around it. We decided to remove the inline JavaScript evaluation feature completely from the code of our Less.js fork. This fix is available in less-openui5 version 0.10.0.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| SAP | less-openui5 | before 0.10.0 | 0.10.0 | Patch available | CNA |
| — | less-openui5 (npm) | before 0.10.0 | 0.10.0 | Patch available | GHSA-3crj-w4f5-gwh4 |
- less-openui5 VendorSAP Affected before 0.10.0 Fixed in 0.10.0 Patch available CNA
- less-openui5 (npm) Vendor— Affected before 0.10.0 Fixed in 0.10.0 Patch available GHSA-3crj-w4f5-gwh4
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:less-openui5_project:less-openui5:*:*:*:*:*:node.js:*:* | before 0.10.0 | Vulnerable | Less-openui5 Project |
- cpe:2.3:a:less-openui5_project:less-openui5:*:*:*:*:*:node.js:*:* Versions before 0.10.0 Vulnerable ·Less-openui5 Project
Remediation
- Fix · CNA less-openui5 (SAP) Fixed in 0.10.0
- Fix · GHSA-3crj-w4f5-gwh4 less-openui5 (npm) Fixed in 0.10.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2021-21316
- 2026-10-03 Alias added: GHSA-3crj-w4f5-gwh4
References
Advisory 5
More SAP vulnerabilities
- TI-2025-22522 Missing Authorization check in SAP NetWeaver (Visual Composer development server) KEVCVSS 3.1CRITICAL 10.0
- TI-2022-06811 SAP NetWeaver Application Server ABAP, SAP NetWeaver Application Server Java, ABAP… KEVCVSS 3.1CRITICAL 10.0
- TI-2021-15842 Path traversal in SAP NetWeaver KEVCVSS 3.1CRITICAL 9.9
- TI-2020-05139 Missing authentication in SAP NetWeaver AS JAVA KEVCVSS 3.1CRITICAL 10.0
- TI-2020-05063 Missing authentication in SAP Solution Manager KEVCVSS 3.1CRITICAL 9.8
- TI-2019-00284 Deserialization of untrusted data in SAP Commerce Cloud KEVCVSS 3.1CRITICAL 9.8
Sources
- CVE-2021-21316 · CVE Program
- CVE-2021-21316 · NVD
- FIRST EPSS
- GHSA-3crj-w4f5-gwh4 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences