Prefix escape
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Partial Red Hat: 1 without a fix
Attack profile from CVSS 3.1 · CNA. Fix status from CNA, GitHub and Red Hat.
Summary
fastify-http-proxy is an npm package which is a fastify plugin for proxying your http requests to another server, with hooks. By crafting a specific URL, it is possible to escape the prefix of the proxied backend service. If the base url of the proxied server is `/pub/`, a user expect that accessing `/priv` on the target service would not be possible. In affected versions, it is possible. This is fixed in version 4.3.1.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| fastify | fastify-http-proxy | before 4.3.1 | 4.3.1 | Patch available | CNA |
| — | fastify-http-proxy (npm) | before 4.3.1 | 4.3.1 | Patch available | GHSA-c4qr-gmr9-v23w |
- fastify-http-proxy Vendorfastify Affected before 4.3.1 Fixed in 4.3.1 Patch available CNA
- fastify-http-proxy (npm) Vendor— Affected before 4.3.1 Fixed in 4.3.1 Patch available GHSA-c4qr-gmr9-v23w
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:fastify-http-proxy_project:fastify-http-proxy:*:*:*:*:*:node.js:*:* | before 4.3.1 | Vulnerable | Fastify-http-proxy Project |
- cpe:2.3:a:fastify-http-proxy_project:fastify-http-proxy:*:*:*:*:*:node.js:*:* Versions before 4.3.1 Vulnerable ·Fastify-http-proxy Project
Remediation
- Fix · CNA fastify-http-proxy (fastify) Fixed in 4.3.1
- Fix · GHSA-c4qr-gmr9-v23w fastify-http-proxy (npm) Fixed in 4.3.1 Advisory →
Red Hat 1 advisory
- RHSA-2021:1168 Released 2021-04-13 · Red Hat rating ImportantRed Hat Advanced Cluster Management 2.2.2 security and bug fix update
- Red Hat Advanced Cluster Management for Kubernetes 2.2 for RHEL 7 rhacm2/management-ingress-rhel7, rhacm2/memcached-exporter-rhel7, rhacm2/openshift-hive-rhel7 +2
- Red Hat Advanced Cluster Management for Kubernetes 2.2 for RHEL 8 rhacm2/acm-must-gather-rhel8, rhacm2/acm-operator-bundle, rhacm2/acmesolver-rhel8 +47
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Advanced Cluster Management for Kubernetes 2 | Affected | No fix yet |
Timeline
- 2026-10-02 Threatist record created from CVE-2021-21322
- 2026-10-03 Alias added: GHSA-c4qr-gmr9-v23w
References
More fastify vulnerabilities
- TI-2026-26180 @fastify/express vulnerable to middleware authentication bypass via URL normalization… CVSS 4.0CRITICAL 9.1
- TI-2026-26179 @fastify/express vulnerable to middleware path doubling causing authentication bypass in child plugin scopes CVSS 3.1CRITICAL 9.1
- TI-2026-26177 @fastify/reply-from vulnerable to connection header abuse enabling stripping of proxy-added headers CVSS 4.0CRITICAL 9.0
- TI-2026-05498 @fastify/middie vulnerable to middleware authentication bypass in child plugin scopes CVSS 3.1CRITICAL 9.1
- TI-2023-15307 Cross-site request forgery in npm @fastify/oauth2 CVSS 3.1HIGH 8.8
- TI-2022-18664 Denial of service in Fastify via Content-Type header CVSS 3.1HIGH 7.5
Sources
- CVE-2021-21322 · CVE Program
- CVE-2021-21322 · NVD
- FIRST EPSS
- GHSA-c4qr-gmr9-v23w · GitHub Advisory Database · CC BY 4.0
- CVE-2021-21322 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences