Exposure of Sensitive Information to an Unauthorized Actor in Products.PluggableAuthService ZODBRoleManager
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-200.
Summary
Products.PluggableAuthService is a pluggable Zope authentication and authorization framework. In Products.PluggableAuthService before version 2.6.0 there is an information disclosure vulnerability - everyone can list the names of roles defined in the ZODB Role Manager plugin if the site uses this plugin. The problem has been fixed in version 2.6.0. Depending on how you have installed Products.PluggableAuthService, you should change the buildout version pin to 2.6.0 and re-run the buildout, or if you used pip simply do `pip install "Products.PluggableAuthService>=2.6.0"`.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| zopefoundation | Products.PluggableAuthService | before 2.6.0 | 2.6.0 | Patch available | CNA |
| — | Products.PluggableAuthService (PyPI) | before 2.6.0 | 2.6.0 | Patch available | GHSA-p75f-g7gx-2r7p |
- Products.PluggableAuthService Vendorzopefoundation Affected before 2.6.0 Fixed in 2.6.0 Patch available CNA
- Products.PluggableAuthService (PyPI) Vendor— Affected before 2.6.0 Fixed in 2.6.0 Patch available GHSA-p75f-g7gx-2r7p
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:zope:products.pluggableauthservice:*:*:*:*:*:*:*:* | before 2.6.0 | Vulnerable | zopefoundation |
| cpe:2.3:a:plone:plone:*:*:*:*:*:*:*:* | 4.3.0 – 4.3.20; 5.0 – 5.2.4 | Vulnerable | plone |
- cpe:2.3:a:zope:products.pluggableauthservice:*:*:*:*:*:*:*:* Versions before 2.6.0 Vulnerable ·zopefoundation
- cpe:2.3:a:plone:plone:*:*:*:*:*:*:*:* Versions 4.3.0 – 4.3.20; 5.0 – 5.2.4 Vulnerable ·plone
Remediation
- Fix · CNA Products.PluggableAuthService (zopefoundation) Fixed in 2.6.0
- Fix · GHSA-p75f-g7gx-2r7p Products.PluggableAuthService (PyPI) Fixed in 2.6.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2021-21336
- 2026-10-03 Alias added: GHSA-p75f-g7gx-2r7p
References
Advisory 5
- https://github.com/zopefoundation/Products.PluggableAuthService/security/advisories/GHSA-p75f-g7gx-2r7p
- https://pypi.org/project/Products.PluggableAuthService/
- [oss-security] 20210521 Plone security hotfix 20210518
- [oss-security] 20210522 Re: Plone security hotfix 20210518
- https://nvd.nist.gov/vuln/detail/CVE-2021-21336
More zopefoundation Products.pluggableauthservice vulnerabilities
- TI-2021-04437 URL Redirection to Untrusted Site ('Open Redirect') in Products.PluggableAuthService CVSS 3.1MEDIUM 6.1
Sources
- CVE-2021-21336 · CVE Program
- CVE-2021-21336 · NVD
- FIRST EPSS
- GHSA-p75f-g7gx-2r7p · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences