Cross-Site Scripting in Content Preview
Priority LOW 26CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
TYPO3 is an open source PHP based web content management system. In TYPO3 before versions 10.4.14, 11.1.1 it has been discovered that database fields used as _descriptionColumn_ are vulnerable to cross-site scripting when their content gets previewed. A valid backend user account is needed to exploit this vulnerability. This is fixed in versions 10.4.14, 11.1.1 .
Why it matters now
EPSS 0.00872 59th percentileScored 2026-11-07
Fix Fixed typo3/cms-backend (Packagist): 10.4.14, 11.1.1typo3/cms-core (Packagist): 10.4.14, 11.1.1+1 more product
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| TYPO3 | TYPO3.CMS | 10.0.0 – 10.4.13; 11.0.0 – 11.1.0 | — | No fix listed | CNA |
| — | typo3/cms-backend (Packagist) | 10.0.0 to before 10.4.14 | 10.4.14 | Patch available | GHSA-fjh3-g8gq-9q92 |
| — | typo3/cms-backend (Packagist) | 11.0.0 to before 11.1.1 | 11.1.1 | Patch available | GHSA-fjh3-g8gq-9q92 |
| — | typo3/cms-core (Packagist) | 10.0.0 to before 10.4.14 | 10.4.14 | Patch available | GHSA-fjh3-g8gq-9q92 |
| — | typo3/cms-core (Packagist) | 11.0.0 to before 11.1.1 | 11.1.1 | Patch available | GHSA-fjh3-g8gq-9q92 |
| — | typo3/cms (Packagist) | 10.0.0 to before 10.4.14 | 10.4.14 | Patch available | GHSA-fjh3-g8gq-9q92 |
| — | typo3/cms (Packagist) | 11.0.0 to before 11.1.1 | 11.1.1 | Patch available | GHSA-fjh3-g8gq-9q92 |
- TYPO3.CMS VendorTYPO3 Affected 10.0.0 – 10.4.13; 11.0.0 – 11.1.0 Fixed in — No fix listed CNA
- typo3/cms-backend (Packagist) Vendor— Affected 10.0.0 to before 10.4.14 Fixed in 10.4.14 Patch available GHSA-fjh3-g8gq-9q92
- typo3/cms-backend (Packagist) Vendor— Affected 11.0.0 to before 11.1.1 Fixed in 11.1.1 Patch available GHSA-fjh3-g8gq-9q92
- typo3/cms-core (Packagist) Vendor— Affected 10.0.0 to before 10.4.14 Fixed in 10.4.14 Patch available GHSA-fjh3-g8gq-9q92
- typo3/cms-core (Packagist) Vendor— Affected 11.0.0 to before 11.1.1 Fixed in 11.1.1 Patch available GHSA-fjh3-g8gq-9q92
- typo3/cms (Packagist) Vendor— Affected 10.0.0 to before 10.4.14 Fixed in 10.4.14 Patch available GHSA-fjh3-g8gq-9q92
- typo3/cms (Packagist) Vendor— Affected 11.0.0 to before 11.1.1 Fixed in 11.1.1 Patch available GHSA-fjh3-g8gq-9q92
Remediation
- Fix · GHSA-fjh3-g8gq-9q92 typo3/cms-backend (Packagist) Fixed in 10.4.14 Advisory →
- Fix · GHSA-fjh3-g8gq-9q92 typo3/cms-backend (Packagist) Fixed in 11.1.1 Advisory →
- Fix · GHSA-fjh3-g8gq-9q92 typo3/cms-core (Packagist) Fixed in 10.4.14 Advisory →
- Fix · GHSA-fjh3-g8gq-9q92 typo3/cms-core (Packagist) Fixed in 11.1.1 Advisory →
- Fix · GHSA-fjh3-g8gq-9q92 typo3/cms (Packagist) Fixed in 10.4.14 Advisory →
- Fix · GHSA-fjh3-g8gq-9q92 typo3/cms (Packagist) Fixed in 11.1.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2021-21340
- 2026-10-03 Alias added: GHSA-fjh3-g8gq-9q92
References
Advisory 4
More Typo3 vulnerabilities
- TI-2023-10314 Persisted Cross-Site Scripting in Frontend Rendering in typo3 CVSS 3.1HIGH 8.8
- TI-2010-03538 The jumpUrl (aka access tracking) implementation in tslib/class.tslib_fe.php in TYPO3… CVSS 2.0HIGH 7.1
- TI-2009-00775 The jumpUrl mechanism in class.tslib_fe.php in TYPO3 3.3.x through 3.8.x, 4.0 before… CVSS 2.0MEDIUM 5.0
- TI-2009-00241 The Indexed Search Engine (indexed_search) system extension in TYPO3 4.0.0 through 4.0.9… CVSS 2.0HIGH 10.0
- TI-2020-08940 Improperly Controlled Modification of Dynamically-Determined Object Attributes in TYPO3 CMS CVSS 3.1CRITICAL 10.0
- TI-2011-03994 Improper authentication in TYPO3 CVSS 3.1CRITICAL 9.8
Sources
- CVE-2021-21340 · CVE Program
- CVE-2021-21340 · NVD
- FIRST EPSS
- GHSA-fjh3-g8gq-9q92 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences