Sensitive information disclosure via log in com.bmuschko:gradle-vagrant-plugin
Priority LOW 31CWE-532Published · Updated
Key facts
- Attack vector
- Adjacent network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-532.
Summary
The `com.bmuschko:gradle-vagrant-plugin` Gradle plugin contains an information disclosure vulnerability due to the logging of the system environment variables. When this Gradle plugin is executed in public CI/CD, this can lead to sensitive credentials being exposed to malicious actors. This is fixed in version 3.0.0.
Why it matters now
EPSS 0.01176 67th percentileScored 2026-11-07
Public exploit Yes 2 exploit referencesTagged by NVD
Fix Fixed security-research (JLLeitschuh): 3.0.0com.bmuschko:gradle-vagrant-plugin (Maven): 3.0.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| JLLeitschuh | security-research | before 3.0.0 | 3.0.0 | Patch available | CNA |
| — | com.bmuschko:gradle-vagrant-plugin (Maven) | 0.6 to before 3.0.0 | 3.0.0 | Patch available | GHSA-jpcm-4485-69p7 |
- security-research VendorJLLeitschuh Affected before 3.0.0 Fixed in 3.0.0 Patch available CNA
- com.bmuschko:gradle-vagrant-plugin (Maven) Vendor— Affected 0.6 to before 3.0.0 Fixed in 3.0.0 Patch available GHSA-jpcm-4485-69p7
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:vagrant_project:vagrant:*:*:*:*:*:gradle:*:* | before 0.6; 2.0 to before 3.0.0 | Vulnerable | Vagrant Project |
- cpe:2.3:a:vagrant_project:vagrant:*:*:*:*:*:gradle:*:* Versions before 0.6; 2.0 to before 3.0.0 Vulnerable ·Vagrant Project
Remediation
- Fix · CNA security-research (JLLeitschuh) Fixed in 3.0.0
- Fix · GHSA-jpcm-4485-69p7 com.bmuschko:gradle-vagrant-plugin (Maven) Fixed in 3.0.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2021-21361
- 2026-10-03 Alias added: GHSA-jpcm-4485-69p7
References
Exploit 2
Patch 2
Sources
- CVE-2021-21361 · CVE Program
- CVE-2021-21361 · NVD
- FIRST EPSS
- GHSA-jpcm-4485-69p7 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences