Cross-Site Scripting in Content Rendering
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Bootstrap Package is a theme for TYPO3. It has been discovered that rendering content in the website frontend is vulnerable to cross-site scripting. A valid backend user account is needed to exploit this vulnerability. Users of the extension, who have overwritten the affected templates with custom code must manually apply the security fix. Update to version 7.1.2, 8.0.8, 9.1.4, 10.0.10 or 11.0.3 of the Bootstrap Package that fix the problem described. Updated version are available from the TYPO3 extension manager, Packagist and at https://extensions.typo3.org/extension/download/bootstrap_package/.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| benjaminkott | bootstrap_package | 7.1.0 to before 7.1.2; 8.0.0 to before 8.0.8; 9.0.0 to before 9.0.4; 9.1.0 to before 9.1.3; 10.0.0 to before 10.0.10; 11.0.0 to before 11.0.3 | 7.1.2, 8.0.8, 9.0.4, 9.1.3, 10.0.10, 11.0.3 | Patch available | CNA |
| — | bk2k/bootstrap-package (Packagist) | 7.1.0 to before 7.1.2 | 7.1.2 | Patch available | GHSA-p48w-vf3c-rqjx |
| — | bk2k/bootstrap-package (Packagist) | 8.0.0 to before 8.0.8 | 8.0.8 | Patch available | GHSA-p48w-vf3c-rqjx |
| — | bk2k/bootstrap-package (Packagist) | 9.0.0 to before 9.0.4 | 9.0.4 | Patch available | GHSA-p48w-vf3c-rqjx |
| — | bk2k/bootstrap-package (Packagist) | 9.1.0 to before 9.1.3 | 9.1.3 | Patch available | GHSA-p48w-vf3c-rqjx |
| — | bk2k/bootstrap-package (Packagist) | 10.0.0 to before 10.0.10 | 10.0.10 | Patch available | GHSA-p48w-vf3c-rqjx |
| — | bk2k/bootstrap-package (Packagist) | 11.0.0 to before 11.0.3 | 11.0.3 | Patch available | GHSA-p48w-vf3c-rqjx |
- bootstrap_package Vendorbenjaminkott Affected 7.1.0 to before 7.1.2; 8.0.0 to before 8.0.8; 9.0.0 to before 9.0.4; 9.1.0 to before 9.1.3; 10.0.0 to before 10.0.10; 11.0.0 to before 11.0.3 Fixed in 7.1.2, 8.0.8, 9.0.4, 9.1.3, 10.0.10, 11.0.3 Patch available CNA
- bk2k/bootstrap-package (Packagist) Vendor— Affected 7.1.0 to before 7.1.2 Fixed in 7.1.2 Patch available GHSA-p48w-vf3c-rqjx
- bk2k/bootstrap-package (Packagist) Vendor— Affected 8.0.0 to before 8.0.8 Fixed in 8.0.8 Patch available GHSA-p48w-vf3c-rqjx
- bk2k/bootstrap-package (Packagist) Vendor— Affected 9.0.0 to before 9.0.4 Fixed in 9.0.4 Patch available GHSA-p48w-vf3c-rqjx
- bk2k/bootstrap-package (Packagist) Vendor— Affected 9.1.0 to before 9.1.3 Fixed in 9.1.3 Patch available GHSA-p48w-vf3c-rqjx
- bk2k/bootstrap-package (Packagist) Vendor— Affected 10.0.0 to before 10.0.10 Fixed in 10.0.10 Patch available GHSA-p48w-vf3c-rqjx
- bk2k/bootstrap-package (Packagist) Vendor— Affected 11.0.0 to before 11.0.3 Fixed in 11.0.3 Patch available GHSA-p48w-vf3c-rqjx
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:typo3:typo3:*:*:*:*:*:*:*:* | before 7.1.2; 8.0.0 to before 8.0.8; 9.0.0 to before 9.0.4; 9.1.0 to before 9.1.3; 10.0.0 to before 10.0.10; 11.0.0 to before 11.0.3 | Vulnerable | TYPO3 |
- cpe:2.3:a:typo3:typo3:*:*:*:*:*:*:*:* Versions before 7.1.2; 8.0.0 to before 8.0.8; 9.0.0 to before 9.0.4; 9.1.0 to before 9.1.3; 10.0.0 to before 10.0.10; 11.0.0 to before 11.0.3 Vulnerable ·TYPO3
Remediation
- Fix · CNA bootstrap_package (benjaminkott) Fixed in 7.1.2, 8.0.8, 9.0.4, 9.1.3, 10.0.10, 11.0.3
- Fix · GHSA-p48w-vf3c-rqjx bk2k/bootstrap-package (Packagist) Fixed in 7.1.2 Advisory →
- Fix · GHSA-p48w-vf3c-rqjx bk2k/bootstrap-package (Packagist) Fixed in 8.0.8 Advisory →
- Fix · GHSA-p48w-vf3c-rqjx bk2k/bootstrap-package (Packagist) Fixed in 9.0.4 Advisory →
- Fix · GHSA-p48w-vf3c-rqjx bk2k/bootstrap-package (Packagist) Fixed in 9.1.3 Advisory →
- Fix · GHSA-p48w-vf3c-rqjx bk2k/bootstrap-package (Packagist) Fixed in 10.0.10 Advisory →
- Fix · GHSA-p48w-vf3c-rqjx bk2k/bootstrap-package (Packagist) Fixed in 11.0.3 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2021-21365
- 2026-10-03 Alias added: GHSA-p48w-vf3c-rqjx
References
Exploit 2
Patch 1
More Typo3 vulnerabilities
- TI-2023-10314 Persisted Cross-Site Scripting in Frontend Rendering in typo3 CVSS 3.1HIGH 8.8
- TI-2010-03538 The jumpUrl (aka access tracking) implementation in tslib/class.tslib_fe.php in TYPO3… CVSS 2.0HIGH 7.1
- TI-2009-00775 The jumpUrl mechanism in class.tslib_fe.php in TYPO3 3.3.x through 3.8.x, 4.0 before… CVSS 2.0MEDIUM 5.0
- TI-2009-00241 The Indexed Search Engine (indexed_search) system extension in TYPO3 4.0.0 through 4.0.9… CVSS 2.0HIGH 10.0
- TI-2020-08940 Improperly Controlled Modification of Dynamically-Determined Object Attributes in TYPO3 CMS CVSS 3.1CRITICAL 10.0
- TI-2011-03994 Improper authentication in TYPO3 CVSS 3.1CRITICAL 9.8
Sources
- CVE-2021-21365 · CVE Program
- CVE-2021-21365 · NVD
- FIRST EPSS
- GHSA-p48w-vf3c-rqjx · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences