Command injection vulnerability in @prisma/sdk in getPackedPackage function
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- High
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-78.
Summary
Prisma is an open source ORM for Node.js & TypeScript. As of today, we are not aware of any Prisma users or external consumers of the `@prisma/sdk` package who are affected by this security vulnerability. This issue may lead to remote code execution if a client of the library calls the vulnerable method with untrusted input. It only affects the `getPackedPackage` function and this function is not advertised and only used for tests & building our CLI, no malicious code was found after checking our codebase.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| prisma | prisma | before 2.20.0 | 2.20.0 | Patch available | CNA |
| — | @prisma/sdk (npm) | before 2.20.0 | 2.20.0 | Patch available | GHSA-pxcc-hj8w-fmm7 |
- prisma Vendorprisma Affected before 2.20.0 Fixed in 2.20.0 Patch available CNA
- @prisma/sdk (npm) Vendor— Affected before 2.20.0 Fixed in 2.20.0 Patch available GHSA-pxcc-hj8w-fmm7
Remediation
- Fix · CNA prisma (prisma) Fixed in 2.20.0
- Fix · GHSA-pxcc-hj8w-fmm7 @prisma/sdk (npm) Fixed in 2.20.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2021-21414
- 2026-10-03 Alias added: GHSA-pxcc-hj8w-fmm7
References
Sources
- CVE-2021-21414 · CVE Program
- CVE-2021-21414 · NVD
- FIRST EPSS
- GHSA-pxcc-hj8w-fmm7 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences