Potential XSS injection in the newsletter conditions field
Priority LOW 26CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
ps_emailsubscription is a newsletter subscription module for the PrestaShop platform. An employee can inject javascript in the newsletter condition field that will then be executed on the front office The issue has been fixed in 2.6.1
Why it matters now
EPSS 0.00786 56th percentileScored 2026-11-07
Fix Fixed ps_emailsubscription (PrestaShop): 2.6.1prestashop/ps_emailsubscription (Packagist): 2.6.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| PrestaShop | ps_emailsubscription | before 2.6.1 | 2.6.1 | Patch available | CNA |
| — | prestashop/ps_emailsubscription (Packagist) | before 2.6.1 | 2.6.1 | Patch available | GHSA-vwfx-hh3w-fj99 |
- ps_emailsubscription VendorPrestaShop Affected before 2.6.1 Fixed in 2.6.1 Patch available CNA
- prestashop/ps_emailsubscription (Packagist) Vendor— Affected before 2.6.1 Fixed in 2.6.1 Patch available GHSA-vwfx-hh3w-fj99
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:prestashop:ps_emailsubscription:*:*:*:*:*:prestashop:*:* | 2.6.0 to before 2.6.1 | Vulnerable | PrestaShop |
- cpe:2.3:a:prestashop:ps_emailsubscription:*:*:*:*:*:prestashop:*:* Versions 2.6.0 to before 2.6.1 Vulnerable ·PrestaShop
Remediation
- Fix · CNA ps_emailsubscription (PrestaShop) Fixed in 2.6.1
- Fix · GHSA-vwfx-hh3w-fj99 prestashop/ps_emailsubscription (Packagist) Fixed in 2.6.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2021-21418
- 2026-10-03 Alias added: GHSA-vwfx-hh3w-fj99
References
Patch 1
Sources
- CVE-2021-21418 · CVE Program
- CVE-2021-21418 · NVD
- FIRST EPSS
- GHSA-vwfx-hh3w-fj99 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences