Incorrect authorization in SAP NetWeaver AS JAVA
Priority LOW 39CWE-863Published · Updated
Key facts
- Attack vector
- Adjacent network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-863.
Summary
The MigrationService, which is part of SAP NetWeaver versions 7.10, 7.11, 7.20, 7.30, 7.31, 7.40, 7.50, does not perform an authorization check. This might allow an unauthorized attacker to access configuration objects, including such that grant administrative privileges. This could result in complete compromise of system confidentiality, integrity, and availability.
Why it matters now
EPSS 0.00505 43rd percentileScored 2026-11-07
Fix Fixed SAP NetWeaver AS JAVA (MigrationService) (SAP SE): 7.10, 7.11, 7.30 +3
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| SAP | SAP NetWeaver AS JAVA (MigrationService) | before 7.10; before 7.11; before 7.30; before 7.31; before 7.40; before 7.50 | 7.10, 7.11, 7.30, 7.31, 7.40, 7.50 | Patch available | CNA |
- SAP NetWeaver AS JAVA (MigrationService) VendorSAP Affected before 7.10; before 7.11; before 7.30; before 7.31; before 7.40; before 7.50 Fixed in 7.10, 7.11, 7.30, 7.31, 7.40, 7.50 Patch available CNA
CPE configurations NVD · 7
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:sap:netweaver:7.10:*:*:*:*:*:*:* | 7.10 | Vulnerable | SAP |
| cpe:2.3:a:sap:netweaver:7.11:*:*:*:*:*:*:* | 7.11 | Vulnerable | SAP |
| cpe:2.3:a:sap:netweaver:7.20:*:*:*:*:*:*:* | 7.20 | Vulnerable | SAP |
| cpe:2.3:a:sap:netweaver:7.30:*:*:*:*:*:*:* | 7.30 | Vulnerable | SAP |
| cpe:2.3:a:sap:netweaver:7.31:*:*:*:*:*:*:* | 7.31 | Vulnerable | SAP |
| cpe:2.3:a:sap:netweaver:7.40:*:*:*:*:*:*:* | 7.40 | Vulnerable | SAP |
| cpe:2.3:a:sap:netweaver:7.50:*:*:*:*:*:*:* | 7.50 | Vulnerable | SAP |
- cpe:2.3:a:sap:netweaver:7.10:*:*:*:*:*:*:* Versions 7.10 Vulnerable ·SAP
- cpe:2.3:a:sap:netweaver:7.11:*:*:*:*:*:*:* Versions 7.11 Vulnerable ·SAP
- cpe:2.3:a:sap:netweaver:7.20:*:*:*:*:*:*:* Versions 7.20 Vulnerable ·SAP
- cpe:2.3:a:sap:netweaver:7.30:*:*:*:*:*:*:* Versions 7.30 Vulnerable ·SAP
- cpe:2.3:a:sap:netweaver:7.31:*:*:*:*:*:*:* Versions 7.31 Vulnerable ·SAP
- cpe:2.3:a:sap:netweaver:7.40:*:*:*:*:*:*:* Versions 7.40 Vulnerable ·SAP
- cpe:2.3:a:sap:netweaver:7.50:*:*:*:*:*:*:* Versions 7.50 Vulnerable ·SAP
Remediation
- Fix · CNA SAP NetWeaver AS JAVA (MigrationService) (SAP SE) Fixed in 7.10, 7.11, 7.30, 7.31, 7.40, 7.50
Timeline
- 2026-10-02 Threatist record created from CVE-2021-21481
- 2026-10-03 Alias added: GHSA-cwx3-9577-fcx4
References
More SAP Netweaver vulnerabilities
- TI-2025-22522 Missing Authorization check in SAP NetWeaver (Visual Composer development server) KEVCVSS 3.1CRITICAL 10.0
- TI-2021-15842 Path traversal in SAP NetWeaver KEVCVSS 3.1CRITICAL 9.9
- TI-2025-27866 Insecure Deserialization in SAP NetWeaver (Visual Composer development server) KEVCVSS 3.1CRITICAL 9.1
- TI-2012-02262 The DiagTraceR3Info function in the Dialog processor in disp+work.exe 7010.29.15.58313… CVSS 2.0HIGH 9.3
- TI-2013-01399 A Buffer Overflow vulnerability exists in the Message Server service… CVSS 3.1CRITICAL 9.8
- TI-2016-02149 Directory traversal vulnerability in the GetFileList function in the SAP Manufacturing… CVSS 3.0HIGH 7.5
Sources
- CVE-2021-21481 · CVE Program
- CVE-2021-21481 · NVD
- FIRST EPSS
- GHSA-cwx3-9577-fcx4 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences