Improper authentication in Dell PowerScale OneFS
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-287.
Summary
Dell PowerScale OneFS versions 8.1.0 – 9.1.0 contain a "use of SSH key past account expiration" vulnerability. A user on the network with the ISI_PRIV_AUTH_SSH RBAC privilege that has an expired account may potentially exploit this vulnerability, giving them access to the same things they had before account expiration. This may by a high privileged account and hence Dell recommends customers upgrade at the earliest opportunity.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Dell | PowerScale OneFS | before 8.1.2 / 8.2.2 / 9.1.0.x / Empire / Main | 8.1.2 / 8.2.2 / 9.1.0.x / Empire / Main | Patch available | CNA |
- PowerScale OneFS VendorDell Affected before 8.1.2 / 8.2.2 / 9.1.0.x / Empire / Main Fixed in 8.1.2 / 8.2.2 / 9.1.0.x / Empire / Main Patch available CNA
CPE configurations NVD · 8
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:dell:emc_powerscale_onefs:8.1.0:*:*:*:*:*:*:* | 8.1.0 | Vulnerable | Dell |
| cpe:2.3:o:dell:emc_powerscale_onefs:8.1.1:*:*:*:*:*:*:* | 8.1.1 | Vulnerable | Dell |
| cpe:2.3:o:dell:emc_powerscale_onefs:8.1.2:*:*:*:*:*:*:* | 8.1.2 | Vulnerable | Dell |
| cpe:2.3:o:dell:emc_powerscale_onefs:8.2.0:*:*:*:*:*:*:* | 8.2.0 | Vulnerable | Dell |
| cpe:2.3:o:dell:emc_powerscale_onefs:8.2.1:*:*:*:*:*:*:* | 8.2.1 | Vulnerable | Dell |
| cpe:2.3:o:dell:emc_powerscale_onefs:8.2.2:*:*:*:*:*:*:* | 8.2.2 | Vulnerable | Dell |
| cpe:2.3:o:dell:emc_powerscale_onefs:9.0.0:*:*:*:*:*:*:* | 9.0.0 | Vulnerable | Dell |
| cpe:2.3:o:dell:emc_powerscale_onefs:9.1.0:*:*:*:*:*:*:* | 9.1.0 | Vulnerable | Dell |
- cpe:2.3:o:dell:emc_powerscale_onefs:8.1.0:*:*:*:*:*:*:* Versions 8.1.0 Vulnerable ·Dell
- cpe:2.3:o:dell:emc_powerscale_onefs:8.1.1:*:*:*:*:*:*:* Versions 8.1.1 Vulnerable ·Dell
- cpe:2.3:o:dell:emc_powerscale_onefs:8.1.2:*:*:*:*:*:*:* Versions 8.1.2 Vulnerable ·Dell
- cpe:2.3:o:dell:emc_powerscale_onefs:8.2.0:*:*:*:*:*:*:* Versions 8.2.0 Vulnerable ·Dell
- cpe:2.3:o:dell:emc_powerscale_onefs:8.2.1:*:*:*:*:*:*:* Versions 8.2.1 Vulnerable ·Dell
- cpe:2.3:o:dell:emc_powerscale_onefs:8.2.2:*:*:*:*:*:*:* Versions 8.2.2 Vulnerable ·Dell
- cpe:2.3:o:dell:emc_powerscale_onefs:9.0.0:*:*:*:*:*:*:* Versions 9.0.0 Vulnerable ·Dell
- cpe:2.3:o:dell:emc_powerscale_onefs:9.1.0:*:*:*:*:*:*:* Versions 9.1.0 Vulnerable ·Dell
Remediation
- Fix · CNA PowerScale OneFS (Dell) Fixed in 8.1.2 / 8.2.2 / 9.1.0.x / Empire / Main
Timeline
- 2026-10-02 Threatist record created from CVE-2021-21502
- 2026-10-03 Alias added: GHSA-pw6f-fxqf-2vxp
References
More Dell Emc Powerscale Onefs vulnerabilities
- TI-2022-22190 Improper privilege management in Dell PowerScale OneFS CVSS 3.1CRITICAL 9.8
- TI-2022-10097 Dell PowerScale OneFS, versions 8.2.x-9.3.x, contain a predictable seed in pseudo-random… CVSS 3.1CRITICAL 9.8
- TI-2022-06835 Missing brute-force protection in Dell PowerScale OneFS CVSS 3.1CRITICAL 9.8
- TI-2022-22189 Improper certificate validation in Dell PowerScale OneFS CVSS 3.1CRITICAL 9.8
- TI-2022-15270 Insufficiently protected credentials in Dell PowerScale OneFS CVSS 3.1CRITICAL 9.8
- TI-2022-10098 Broken or risky cryptographic algorithm in Dell PowerScale OneFS CVSS 3.1CRITICAL 9.8
Sources
- CVE-2021-21502 · CVE Program
- CVE-2021-21502 · NVD
- FIRST EPSS
- GHSA-pw6f-fxqf-2vxp · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences