Uncontrolled search path in Dell SupportAssist Client
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-427.
Summary
Dell SupportAssist Client for Consumer PCs versions 3.7.x, 3.6.x, 3.4.x, 3.3.x, Dell SupportAssist Client for Business PCs versions 2.0.x, 2.1.x, 2.2.x, and Dell SupportAssist Client ProManage 1.x contain a DLL injection vulnerability in the Costura Fody plugin. A local user with low privileges could potentially exploit this vulnerability, leading to the execution of arbitrary executable on the operating system with SYSTEM privileges.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Dell | Dell SupportAssist Client | before SACH 3.8, SACB 2.3 | SACH 3.8, SACB 2.3 | Patch available | CNA |
- Dell SupportAssist Client VendorDell Affected before SACH 3.8, SACB 2.3 Fixed in SACH 3.8, SACB 2.3 Patch available CNA
CPE configurations NVD · 8
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:dell:supportassist_client_promanage:1.0:*:*:*:*:*:*:* | 1.0 | Vulnerable | Dell |
| cpe:2.3:a:dell:supportassist_for_business_pcs:2.0.0:*:*:*:*:*:*:* | 2.0.0 | Vulnerable | Dell |
| cpe:2.3:a:dell:supportassist_for_business_pcs:2.1.0:*:*:*:*:*:*:* | 2.1.0 | Vulnerable | Dell |
| cpe:2.3:a:dell:supportassist_for_business_pcs:2.2.0:*:*:*:*:*:*:* | 2.2.0 | Vulnerable | Dell |
| cpe:2.3:a:dell:supportassist_for_home_pcs:3.3.3:*:*:*:*:*:*:* | 3.3.3 | Vulnerable | Dell |
| cpe:2.3:a:dell:supportassist_for_home_pcs:3.4.0:*:*:*:*:*:*:* | 3.4.0 | Vulnerable | Dell |
| cpe:2.3:a:dell:supportassist_for_home_pcs:3.6.0:*:*:*:*:*:*:* | 3.6.0 | Vulnerable | Dell |
| cpe:2.3:a:dell:supportassist_for_home_pcs:3.7.0:*:*:*:*:*:*:* | 3.7.0 | Vulnerable | Dell |
- cpe:2.3:a:dell:supportassist_client_promanage:1.0:*:*:*:*:*:*:* Versions 1.0 Vulnerable ·Dell
- cpe:2.3:a:dell:supportassist_for_business_pcs:2.0.0:*:*:*:*:*:*:* Versions 2.0.0 Vulnerable ·Dell
- cpe:2.3:a:dell:supportassist_for_business_pcs:2.1.0:*:*:*:*:*:*:* Versions 2.1.0 Vulnerable ·Dell
- cpe:2.3:a:dell:supportassist_for_business_pcs:2.2.0:*:*:*:*:*:*:* Versions 2.2.0 Vulnerable ·Dell
- cpe:2.3:a:dell:supportassist_for_home_pcs:3.3.3:*:*:*:*:*:*:* Versions 3.3.3 Vulnerable ·Dell
- cpe:2.3:a:dell:supportassist_for_home_pcs:3.4.0:*:*:*:*:*:*:* Versions 3.4.0 Vulnerable ·Dell
- cpe:2.3:a:dell:supportassist_for_home_pcs:3.6.0:*:*:*:*:*:*:* Versions 3.6.0 Vulnerable ·Dell
- cpe:2.3:a:dell:supportassist_for_home_pcs:3.7.0:*:*:*:*:*:*:* Versions 3.7.0 Vulnerable ·Dell
Remediation
- Fix · CNA Dell SupportAssist Client (Dell) Fixed in SACH 3.8, SACB 2.3
Timeline
- 2026-10-02 Threatist record created from CVE-2021-21518
- 2026-10-03 Alias added: GHSA-m78j-wwfx-36xp
References
Sources
- CVE-2021-21518 · CVE Program
- CVE-2021-21518 · NVD
- FIRST EPSS
- GHSA-m78j-wwfx-36xp · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences