Cross-site scripting in Jenkins TICS Plugin
Priority LOW 29CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Jenkins TICS Plugin 2020.3.0.6 and earlier does not escape TICS service responses, resulting in a cross-site scripting (XSS) vulnerability exploitable by attackers able to control TICS service response content.
Why it matters now
EPSS 0.00958 61st percentileScored 2026-11-07
Fix Fixed io.jenkins.plugins:tics (Maven): 2020.3.0.7
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Jenkins | Jenkins TICS Plugin | up to 2020.3.0.6 | — | No fix listed | CNA |
| — | io.jenkins.plugins:tics (Maven) | before 2020.3.0.7 | 2020.3.0.7 | Patch available | GHSA-xmw5-45v9-pxqx |
- Jenkins TICS Plugin VendorJenkins Affected up to 2020.3.0.6 Fixed in — No fix listed CNA
- io.jenkins.plugins:tics (Maven) Vendor— Affected before 2020.3.0.7 Fixed in 2020.3.0.7 Patch available GHSA-xmw5-45v9-pxqx
Remediation
- Fix · GHSA-xmw5-45v9-pxqx io.jenkins.plugins:tics (Maven) Fixed in 2020.3.0.7 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2021-21613
- 2026-10-03 Alias added: GHSA-xmw5-45v9-pxqx
References
Sources
- CVE-2021-21613 · CVE Program
- CVE-2021-21613 · NVD
- FIRST EPSS
- GHSA-xmw5-45v9-pxqx · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences