Cross-site request forgery in Jenkins Configuration Slicing Plugin
Priority MEDIUM 40CWE-352Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Tampering
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-352.
Summary
A cross-site request forgery (CSRF) vulnerability in Jenkins Configuration Slicing Plugin 1.51 and earlier allows attackers to apply different slice configurations.
Why it matters now
EPSS 0.00943 61st percentileScored 2026-11-07
Fix Fixed org.jenkins-ci.plugins:configurationslicing (Maven): 1.52
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Jenkins | Jenkins Configuration Slicing Plugin | up to 1.51 | — | No fix listed | CNA |
| — | org.jenkins-ci.plugins:configurationslicing (Maven) | before 1.52 | 1.52 | Patch available | GHSA-42mm-x828-56c7 |
- Jenkins Configuration Slicing Plugin VendorJenkins Affected up to 1.51 Fixed in — No fix listed CNA
- org.jenkins-ci.plugins:configurationslicing (Maven) Vendor— Affected before 1.52 Fixed in 1.52 Patch available GHSA-42mm-x828-56c7
Remediation
- Fix · GHSA-42mm-x828-56c7 org.jenkins-ci.plugins:configurationslicing (Maven) Fixed in 1.52 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2021-21617
- 2026-10-03 Alias added: GHSA-42mm-x828-56c7
References
Advisory 3
Sources
- CVE-2021-21617 · CVE Program
- CVE-2021-21617 · NVD
- FIRST EPSS
- GHSA-42mm-x828-56c7 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences