Cross-site request forgery in Jenkins Libvirt Agents Plugin
Priority MEDIUM 40CWE-352Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Tampering
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-352.
Summary
A cross-site request forgery (CSRF) vulnerability in Jenkins Libvirt Agents Plugin 1.9.0 and earlier allows attackers to stop hypervisor domains.
Why it matters now
EPSS 0.00818 57th percentileScored 2026-11-07
Fix Fixed org.jenkins-ci.plugins:libvirt-slave (Maven): 1.9.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Jenkins | Jenkins Libvirt Agents Plugin | up to 1.9.0 | — | No fix listed | CNA |
| — | org.jenkins-ci.plugins:libvirt-slave (Maven) | before 1.9.1 | 1.9.1 | Patch available | GHSA-mm5c-7mpr-99fm |
- Jenkins Libvirt Agents Plugin VendorJenkins Affected up to 1.9.0 Fixed in — No fix listed CNA
- org.jenkins-ci.plugins:libvirt-slave (Maven) Vendor— Affected before 1.9.1 Fixed in 1.9.1 Patch available GHSA-mm5c-7mpr-99fm
Remediation
- Fix · GHSA-mm5c-7mpr-99fm org.jenkins-ci.plugins:libvirt-slave (Maven) Fixed in 1.9.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2021-21627
- 2026-10-03 Alias added: GHSA-mm5c-7mpr-99fm
References
Advisory 3
Sources
- CVE-2021-21627 · CVE Program
- CVE-2021-21627 · NVD
- FIRST EPSS
- GHSA-mm5c-7mpr-99fm · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences