Jenkins Nuget Plugin 1.0 and earlier does not configure its XML parser to prevent XML external entity (XXE) attacks.
Priority MEDIUM 42CWE-611Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.
Summary
Jenkins Nuget Plugin 1.0 and earlier does not configure its XML parser to prevent XML external entity (XXE) attacks.
Why it matters now
EPSS 0.01536 75th percentileScored 2026-11-07
Fix Fixed org.jenkins-ci.plugins:nuget (Maven): 1.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Jenkins | Jenkins Nuget Plugin | up to 1.0 | — | No fix listed | CNA |
| — | org.jenkins-ci.plugins:nuget (Maven) | before 1.1 | 1.1 | Patch available | GHSA-p674-hh8x-rv5h |
- Jenkins Nuget Plugin VendorJenkins Affected up to 1.0 Fixed in — No fix listed CNA
- org.jenkins-ci.plugins:nuget (Maven) Vendor— Affected before 1.1 Fixed in 1.1 Patch available GHSA-p674-hh8x-rv5h
Remediation
- Fix · GHSA-p674-hh8x-rv5h org.jenkins-ci.plugins:nuget (Maven) Fixed in 1.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2021-21658
- 2026-10-03 Alias added: GHSA-p674-hh8x-rv5h
References
Advisory 3
Sources
- CVE-2021-21658 · CVE Program
- CVE-2021-21658 · NVD
- FIRST EPSS
- GHSA-p674-hh8x-rv5h · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences