Read the docs
TI-2021-04746 Aliases CVE-2021-21666GHSA-8h77-3xwr-hqhh

Cross-site scripting in Jenkins Kiuwan Plugin

Priority LOW 30CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

Jenkins Kiuwan Plugin 1.6.0 and earlier does not escape query parameters in an error message for a form validation endpoint, resulting in a reflected cross-site scripting (XSS) vulnerability.

Why it matters now

EPSS 0.01216 68th percentileScored 2026-11-07
Fix Fixed org.jenkins-ci.plugins:kiuwanJenkinsPlugin (Maven): 1.6.1

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
JenkinsJenkins Kiuwan Pluginup to 1.6.0—No fix listedCNA
—org.jenkins-ci.plugins:kiuwanJenkinsPlugin (Maven)before 1.6.11.6.1Patch availableGHSA-8h77-3xwr-hqhh
  • Jenkins Kiuwan Plugin VendorJenkins Affected up to 1.6.0 Fixed in — No fix listed CNA
  • org.jenkins-ci.plugins:kiuwanJenkinsPlugin (Maven) Vendor— Affected before 1.6.1 Fixed in 1.6.1 Patch available GHSA-8h77-3xwr-hqhh

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:jenkins:kiuwan:*:*:*:*:*:jenkins:*:*up to 1.6.0VulnerableJenkins
  • cpe:2.3:a:jenkins:kiuwan:*:*:*:*:*:jenkins:*:* Versions up to 1.6.0 Vulnerable ·Jenkins

Remediation

  • Fix · GHSA-8h77-3xwr-hqhh org.jenkins-ci.plugins:kiuwanJenkinsPlugin (Maven) Fixed in 1.6.1 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-21666
  2. 2026-10-03 Alias added: GHSA-8h77-3xwr-hqhh

References

Sources