Cross-site scripting in Jenkins Scriptler Plugin
Priority LOW 26CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Jenkins Scriptler Plugin 3.3 and earlier does not escape the name of scripts on the UI when asking to confirm their deletion, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by exploitable by attackers able to create Scriptler scripts.
Why it matters now
EPSS 0.00707 53rd percentileScored 2026-11-07
Fix Fixed org.jenkins-ci.plugins:scriptler (Maven): 3.4
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Jenkins | Jenkins Scriptler Plugin | up to 3.3 | — | No fix listed | CNA |
| — | org.jenkins-ci.plugins:scriptler (Maven) | before 3.4 | 3.4 | Patch available | GHSA-f9gf-2q87-5m44 |
- Jenkins Scriptler Plugin VendorJenkins Affected up to 3.3 Fixed in — No fix listed CNA
- org.jenkins-ci.plugins:scriptler (Maven) Vendor— Affected before 3.4 Fixed in 3.4 Patch available GHSA-f9gf-2q87-5m44
Remediation
- Fix · GHSA-f9gf-2q87-5m44 org.jenkins-ci.plugins:scriptler (Maven) Fixed in 3.4 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2021-21700
- 2026-10-03 Alias added: GHSA-f9gf-2q87-5m44
References
Advisory 3
More Jenkins Scriptler vulnerabilities
- TI-2021-04748 Cross-site scripting in Jenkins Scriptler Plugin CVSS 3.1MEDIUM 5.4
- TI-2021-04747 Cross-site scripting in Jenkins Scriptler Plugin CVSS 3.1MEDIUM 5.4
- TI-2023-27694 Jenkins Scriptler Plugin 342.v6a_89fd40f466 and earlier does not restrict a file name… CVSS 3.1HIGH 8.1
- TI-2023-27695 Missing authorization in Jenkins Scriptler Plugin CVSS 3.1MEDIUM 4.3
Sources
- CVE-2021-21700 · CVE Program
- CVE-2021-21700 · NVD
- FIRST EPSS
- GHSA-f9gf-2q87-5m44 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences