Information disclosure through error messages in GitLab
Priority LOW 22CWE-209Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-209.
Summary
A verbose error message in GitLab EE affecting all versions since 12.2 could disclose the private email address of a user invited to a group
Why it matters now
EPSS 0.00974 62nd percentileScored 2026-11-07
Fix Fixed GitLab (GitLab): 13.12.9, 14.0.7, 14.1.2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| GitLab | GitLab | 12.2 to before 13.12.9; 14.0 to before 14.0.7; 14.1 to before 14.1.2 | 13.12.9, 14.0.7, 14.1.2 | Patch available | CNA |
- GitLab VendorGitLab Affected 12.2 to before 13.12.9; 14.0 to before 14.0.7; 14.1 to before 14.1.2 Fixed in 13.12.9, 14.0.7, 14.1.2 Patch available CNA
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* | 12.2.0 to before 13.12.9 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* | 12.2.0 to before 13.12.9 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* | 14.0.0 to before 14.0.7 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* | 14.0.0 to before 14.0.7 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* | 14.1.0 to before 14.1.2 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* | 14.1.0 to before 14.1.2 | Vulnerable | GitLab |
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* Versions 12.2.0 to before 13.12.9 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* Versions 12.2.0 to before 13.12.9 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* Versions 14.0.0 to before 14.0.7 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* Versions 14.0.0 to before 14.0.7 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* Versions 14.1.0 to before 14.1.2 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* Versions 14.1.0 to before 14.1.2 Vulnerable ·GitLab
Remediation
- Fix · CNA GitLab (GitLab) Fixed in 13.12.9, 14.0.7, 14.1.2
Timeline
- 2026-10-02 Threatist record created from CVE-2021-22249
- 2026-10-03 Alias added: GHSA-5mm2-786g-8qwh
References
More Gitlab vulnerabilities
- TI-2026-71508 Integer overflow in GitLab allows code execution on the server KEVCVSS 3.1CRITICAL 10.0
- TI-2026-58817 Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2023-06425 Weak Password Recovery Mechanism for Forgotten Password in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2021-05191 Code injection in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2021-05161 Server-side request forgery in GitLab KEVCVSS 3.1CRITICAL 9.8
- TI-2022-02763 Injection in GitLab CVSS 3.1CRITICAL 9.9
Sources
- CVE-2021-22249 · CVE Program
- CVE-2021-22249 · NVD
- FIRST EPSS
- GHSA-5mm2-786g-8qwh · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences