Improper privilege management in GitLab
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Privilege escalation
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-269.
Summary
An issue has been discovered in GitLab affecting all versions starting from 13.0 before 14.0.9, all versions starting from 14.1 before 14.1.4, all versions starting from 14.2 before 14.2.2. A user account with 'external' status which is granted 'Maintainer' role on any project on the GitLab instance where 'project tokens' are allowed may elevate its privilege to 'Internal' and access Internal projects.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| GitLab | GitLab | 13.0 to before 14.0.9; 14.1 to before 14.1.4; 14.2 to before 14.2.2 | 14.0.9, 14.1.4, 14.2.2 | Patch available | CNA |
- GitLab VendorGitLab Affected 13.0 to before 14.0.9; 14.1 to before 14.1.4; 14.2 to before 14.2.2 Fixed in 14.0.9, 14.1.4, 14.2.2 Patch available CNA
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* | 13.0.0 to before 14.0.9 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* | 13.0.0 to before 14.0.9 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* | 14.1.0 to before 14.1.4 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* | 14.1.0 to before 14.1.4 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* | 14.2.0 to before 14.2.2 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* | 14.2.0 to before 14.2.2 | Vulnerable | GitLab |
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* Versions 13.0.0 to before 14.0.9 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* Versions 13.0.0 to before 14.0.9 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* Versions 14.1.0 to before 14.1.4 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* Versions 14.1.0 to before 14.1.4 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* Versions 14.2.0 to before 14.2.2 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* Versions 14.2.0 to before 14.2.2 Vulnerable ·GitLab
Remediation
- Fix · CNA GitLab (GitLab) Fixed in 14.0.9, 14.1.4, 14.2.2
Timeline
- 2026-10-02 Threatist record created from CVE-2021-22263
- 2026-10-03 Alias added: GHSA-prvv-j9vx-7x9q
References
More Gitlab vulnerabilities
- TI-2026-71508 Integer overflow in GitLab allows code execution on the server KEVCVSS 3.1CRITICAL 10.0
- TI-2026-58817 Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2023-06425 Weak Password Recovery Mechanism for Forgotten Password in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2021-05191 Code injection in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2021-05161 Server-side request forgery in GitLab KEVCVSS 3.1CRITICAL 9.8
- TI-2022-02763 Injection in GitLab CVSS 3.1CRITICAL 9.9
Sources
- CVE-2021-22263 · CVE Program
- CVE-2021-22263 · NVD
- FIRST EPSS
- GHSA-prvv-j9vx-7x9q · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences