Read the docs
TI-2021-05741 Aliases CVE-2021-22880GHSA-8hc4-xxm3-5ppp

Uncontrolled resource consumption in https://github.com/rails/rails

Priority MEDIUM 40CWE-400Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Denial of service
Confidentiality · integrity · availability
None · None · High
Fix status
Partial Red Hat: 3 without a fix

Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-400.

Summary

The PostgreSQL adapter in Active Record before 6.1.2.1, 6.0.3.5, 5.2.4.5 suffers from a regular expression denial of service (REDoS) vulnerability. Carefully crafted input can cause the input validation in the `money` type of the PostgreSQL adapter in Active Record to spend too much time in a regular expression, resulting in the potential for a DoS attack. This only impacts Rails applications that are using PostgreSQL along with money type columns that take user input.

Why it matters now

EPSS 0.04487 91st percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Partial activerecord (RubyGems): 5.2.4.5, 6.0.3.5, 6.1.2.1Red Hat: 3 without a fix

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—https://github.com/rails/railsFixed in 6.1.2.1, 6.0.3.5, 5.2.4.5—No fix listedCNA
—activerecord (RubyGems)5.0.0 to before 5.2.4.55.2.4.5Patch availableGHSA-8hc4-xxm3-5ppp
—activerecord (RubyGems)6.0.0 to before 6.0.3.56.0.3.5Patch availableGHSA-8hc4-xxm3-5ppp
—activerecord (RubyGems)6.1.0 to before 6.1.2.16.1.2.1Patch availableGHSA-8hc4-xxm3-5ppp
  • https://github.com/rails/rails Vendor— Affected Fixed in 6.1.2.1, 6.0.3.5, 5.2.4.5 Fixed in — No fix listed CNA
  • activerecord (RubyGems) Vendor— Affected 5.0.0 to before 5.2.4.5 Fixed in 5.2.4.5 Patch available GHSA-8hc4-xxm3-5ppp
  • activerecord (RubyGems) Vendor— Affected 6.0.0 to before 6.0.3.5 Fixed in 6.0.3.5 Patch available GHSA-8hc4-xxm3-5ppp
  • activerecord (RubyGems) Vendor— Affected 6.1.0 to before 6.1.2.1 Fixed in 6.1.2.1 Patch available GHSA-8hc4-xxm3-5ppp

CPE configurations NVD · 3

CPEVersionsRoleVendor
cpe:2.3:a:rubyonrails:rails:*:*:*:*:*:*:*:*4.2.0 to before 5.2.4.5; 6.0.0 to before 6.0.3.5; 6.1.0 to before 6.1.2.1VulnerableRails
cpe:2.3:o:fedoraproject:fedora:32:*:*:*:*:*:*:*32VulnerableFedoraproject
cpe:2.3:o:fedoraproject:fedora:33:*:*:*:*:*:*:*33VulnerableFedoraproject
  • cpe:2.3:a:rubyonrails:rails:*:*:*:*:*:*:*:* Versions 4.2.0 to before 5.2.4.5; 6.0.0 to before 6.0.3.5; 6.1.0 to before 6.1.2.1 Vulnerable ·Rails
  • cpe:2.3:o:fedoraproject:fedora:32:*:*:*:*:*:*:* Versions 32 Vulnerable ·Fedoraproject
  • cpe:2.3:o:fedoraproject:fedora:33:*:*:*:*:*:*:* Versions 33 Vulnerable ·Fedoraproject

Remediation

  • Fix · GHSA-8hc4-xxm3-5ppp activerecord (RubyGems) Fixed in 5.2.4.5 Advisory →
  • Fix · GHSA-8hc4-xxm3-5ppp activerecord (RubyGems) Fixed in 6.0.3.5 Advisory →
  • Fix · GHSA-8hc4-xxm3-5ppp activerecord (RubyGems) Fixed in 6.1.2.1 Advisory →

Fixed in the same release

Records fixed by the same vendor advisory or release, as the CNA lists them.

  • Advisory ·

    https://github.com/rails/rails — FEDORA-2021-b571fca1b8

    2 records Highest priority Priority HIGH 1 HIGH, 1 MEDIUM

    Other records, highest priority first

    • TI-2021-05742 Open redirect in https://github.com/rails/railsPriority HIGH 69

Vendor assessments

Red Hat

Red Hat rating: Moderate. Red Hat's page for this CVE →

ProductStatusPlan or fix
CloudForms Management Engine 5AffectedNo fix planned: Will not fix
Red Hat 3scale API Management Platform 2AffectedNo fix yet
Red Hat Satellite 6AffectedNo fix yet: Fix deferred

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-22880
  2. 2026-10-03 Alias added: GHSA-8hc4-xxm3-5ppp

References

Sources