Cross-site scripting (XSS) in apexcharts
Priority LOW 31CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
The package apexcharts before 3.24.0 are vulnerable to Cross-site Scripting (XSS) via lack of sanitization of graph legend fields.
Why it matters now
EPSS 0.01387 72nd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed apexcharts: 3.24.0apexcharts (npm): 3.24.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | apexcharts | before 3.24.0 | 3.24.0 | Patch available | CNA |
| — | apexcharts (npm) | before 3.24.0 | 3.24.0 | Patch available | GHSA-w46j-8hm6-h8mm |
- apexcharts Vendor— Affected before 3.24.0 Fixed in 3.24.0 Patch available CNA
- apexcharts (npm) Vendor— Affected before 3.24.0 Fixed in 3.24.0 Patch available GHSA-w46j-8hm6-h8mm
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:fusioncharts:apexcharts:*:*:*:*:*:node.js:*:* | before 3.24.0 | Vulnerable | Fusioncharts |
- cpe:2.3:a:fusioncharts:apexcharts:*:*:*:*:*:node.js:*:* Versions before 3.24.0 Vulnerable ·Fusioncharts
Remediation
- Fix · CNA apexcharts Fixed in 3.24.0
- Fix · GHSA-w46j-8hm6-h8mm apexcharts (npm) Fixed in 3.24.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2021-23327
- 2026-10-03 Alias added: GHSA-w46j-8hm6-h8mm
References
Sources
- CVE-2021-23327 · CVE Program
- CVE-2021-23327 · NVD
- FIRST EPSS
- GHSA-w46j-8hm6-h8mm · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences