Deserialization of untrusted data in qlib
Priority LOW 38CWE-502Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-502.
Summary
This affects all versions of package qlib. The workflow function in cli part of qlib was using an unsafe YAML load function.
Why it matters now
EPSS 0.03653 89th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed pyqlib (PyPI): 0.7.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | qlib | all versions | — | No fix listed | CNA |
| — | pyqlib (PyPI) | before 0.7.0 | 0.7.0 | Patch available | GHSA-hjr4-fhgp-23g9 |
- qlib Vendor— Affected all versions Fixed in — No fix listed CNA
- pyqlib (PyPI) Vendor— Affected before 0.7.0 Fixed in 0.7.0 Patch available GHSA-hjr4-fhgp-23g9
Remediation
- Fix · GHSA-hjr4-fhgp-23g9 pyqlib (PyPI) Fixed in 0.7.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2021-23338
- 2026-10-03 Alias added: GHSA-hjr4-fhgp-23g9
References
Sources
- CVE-2021-23338 · CVE Program
- CVE-2021-23338 · NVD
- FIRST EPSS
- GHSA-hjr4-fhgp-23g9 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences