Read the docs
TI-2021-06061 Aliases CVE-2021-23368GHSA-hwj9-h5mp-3pm3

Regular expression denial of service (ReDoS) in postcss

Priority LOW 30CWE-400Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Denial of service
Confidentiality · integrity · availability
None · None · Low
Fix status
Partial Red Hat: 2 fixed, 5 without a fix

Attack profile from CVSS 3.1 · CNA. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-400.

Summary

The package postcss from 7.0.0 and before 8.2.10 are vulnerable to Regular Expression Denial of Service (ReDoS) during source map parsing.

Why it matters now

EPSS 0.03511 89th percentileScored 2026-11-07
Fix Partial postcss: 8.2.10postcss (npm): 7.0.36, 8.2.10Red Hat: 2 advisoriesRed Hat: 2 fixed, 5 without a fix

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—postcss7.0.0 and later; before 8.2.108.2.10Patch availableCNA
—postcss (npm)7.0.0 to before 7.0.367.0.36Patch availableGHSA-hwj9-h5mp-3pm3
—postcss (npm)8.0.0 to before 8.2.108.2.10Patch availableGHSA-hwj9-h5mp-3pm3
  • postcss Vendor— Affected 7.0.0 and later; before 8.2.10 Fixed in 8.2.10 Patch available CNA
  • postcss (npm) Vendor— Affected 7.0.0 to before 7.0.36 Fixed in 7.0.36 Patch available GHSA-hwj9-h5mp-3pm3
  • postcss (npm) Vendor— Affected 8.0.0 to before 8.2.10 Fixed in 8.2.10 Patch available GHSA-hwj9-h5mp-3pm3

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:postcss:postcss:*:*:*:*:*:node.js:*:*7.0.0 to before 7.0.36; 8.0.0 to before 8.2.10Vulnerablepostcss
  • cpe:2.3:a:postcss:postcss:*:*:*:*:*:node.js:*:* Versions 7.0.0 to before 7.0.36; 8.0.0 to before 8.2.10 Vulnerable ·postcss

Remediation

  • Fix · CNA postcss Fixed in 8.2.10
  • Fix · GHSA-hwj9-h5mp-3pm3 postcss (npm) Fixed in 7.0.36 Advisory →
  • Fix · GHSA-hwj9-h5mp-3pm3 postcss (npm) Fixed in 8.2.10 Advisory →

Red Hat 2 advisories

  • RHSA-2021:3917 Released 2021-10-19 · Red Hat rating Important
    Red Hat Quay v3.6.0 security, bug fix and enhancement update
    • Quay v3 quay/quay-rhel8
  • RHSA-2021:2438 Released 2021-07-27 · Red Hat rating Moderate
    OpenShift Container Platform 4.8.2 bug fix and security update
    • Red Hat OpenShift Container Platform 4.8 openshift4/driver-toolkit-rhel8, openshift4/egress-router-cni-rhel8, openshift4/network-tools-rhel8 +47

Vendor assessments

Red Hat

Red Hat rating: Moderate. Red Hat's page for this CVE →

ProductStatusPlan or fix
Logging Subsystem for Red Hat OpenShiftAffectedNo fix yet: Fix deferred
OpenShift Service Mesh 2.0AffectedNo fix yet
Red Hat Advanced Cluster Management for Kubernetes 2AffectedNo fix yet
Red Hat OpenShift Container Platform 4AffectedNo fix yet: Fix deferred
Red Hat Virtualization 4AffectedNo fix planned: Will not fix
Quay v3Fixed RHSA-2021:3917
Red Hat OpenShift Container Platform 4.8Fixed RHSA-2021:2438
Not affected: 4 products
  • Quay v3
  • Red Hat Ansible Automation Platform 1.2
  • Red Hat OpenShift Container Platform 3.11
  • Red Hat OpenShift Container Platform 4.8

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-23368
  2. 2026-10-03 Alias added: GHSA-hwj9-h5mp-3pm3

References

Other 13

  • TI-2026-33367 PostCSS: Arbitrary file read and information disclosure via attacker-controlled sourceMappingURL in CSS comments CVSS 3.1CRITICAL 9.1
  • TI-2026-48533 Information disclosure in postcss CVSS 4.0MEDIUM 6.3
  • TI-2021-06075 Regular expression denial of service (ReDoS) in postcss CVSS 3.1HIGH 7.5
  • TI-2023-23794 An issue was discovered in PostCSS before 8.4.31. CVSS 3.1MEDIUM 5.3

Sources