Arbitrary code execution in total.js
Priority MEDIUM 48CWE-94Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-94.
Summary
The package total.js before 3.4.9 are vulnerable to Arbitrary Code Execution via the U.set() and U.get() functions.
Why it matters now
EPSS 0.03603 89th percentileScored 2026-11-07
Fix Fixed total.js: 3.4.9total.js (npm): 3.4.9
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | total.js | before 3.4.9 | 3.4.9 | Patch available | CNA |
| — | total.js (npm) | before 3.4.9 | 3.4.9 | Patch available | GHSA-7fm6-gxqg-2pwr |
- total.js Vendor— Affected before 3.4.9 Fixed in 3.4.9 Patch available CNA
- total.js (npm) Vendor— Affected before 3.4.9 Fixed in 3.4.9 Patch available GHSA-7fm6-gxqg-2pwr
Remediation
- Fix · CNA total.js Fixed in 3.4.9
- Fix · GHSA-7fm6-gxqg-2pwr total.js (npm) Fixed in 3.4.9 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2021-23389
- 2026-10-03 Alias added: GHSA-7fm6-gxqg-2pwr
References
More Total.js vulnerabilities
- TI-2024-32459 An issue in Total.js CMS v.1.0 allows a remote attacker to execute arbitrary code via the func.js file. CVSS 3.1HIGH 8.8
- TI-2022-21645 In Total.js 4 before 0e5ace7, /api/common/ping can achieve remote command execution via… CVSS 3.1HIGH 8.8
- TI-2019-06421 index.js in Total.js Platform before 3.2.3 allows path traversal. CVSS 3.0HIGH 7.5
- TI-2025-10089 Total.js CMS Files Menu cross site scripting CVSS 4.0MEDIUM 4.8
- TI-2025-10016 Total.js CMS Layout admin layouts_save cross site scripting CVSS 4.0MEDIUM 4.8
- TI-2021-06042 Remote code execution (RCE) in total.js CVSS 3.1CRITICAL 9.8
Sources
- CVE-2021-23389 · CVE Program
- CVE-2021-23389 · NVD
- FIRST EPSS
- GHSA-7fm6-gxqg-2pwr · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences