Remote code execution (RCE) in pac-resolver
Priority MEDIUM 47CWE-94Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Partial Red Hat: 1 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-94.
Summary
This affects the package pac-resolver before 5.0.0. This can occur when used with untrusted input, due to unsafe PAC file handling. **NOTE:** The fix for this vulnerability is applied in the node-degenerator library, a dependency written by the same maintainer.
Why it matters now
EPSS 0.02943 87th percentileScored 2026-11-07
Fix Partial pac-resolver: 5.0.0pac-resolver (npm): 5.0.0+1 more productRed Hat: 1 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | pac-resolver | before 5.0.0 | 5.0.0 | Patch available | CNA |
| — | pac-resolver (npm) | before 5.0.0 | 5.0.0 | Patch available | GHSA-9j49-mfvp-vmhm |
| — | degenerator (npm) | before 3.0.1 | 3.0.1 | Patch available | GHSA-9j49-mfvp-vmhm |
- pac-resolver Vendor— Affected before 5.0.0 Fixed in 5.0.0 Patch available CNA
- pac-resolver (npm) Vendor— Affected before 5.0.0 Fixed in 5.0.0 Patch available GHSA-9j49-mfvp-vmhm
- degenerator (npm) Vendor— Affected before 3.0.1 Fixed in 3.0.1 Patch available GHSA-9j49-mfvp-vmhm
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:pac-resolver_project:pac-resolver:*:*:*:*:*:node.js:*:* | before 5.0.0 | Vulnerable | Pac-resolver Project |
- cpe:2.3:a:pac-resolver_project:pac-resolver:*:*:*:*:*:node.js:*:* Versions before 5.0.0 Vulnerable ·Pac-resolver Project
Remediation
- Fix · CNA pac-resolver Fixed in 5.0.0
- Fix · GHSA-9j49-mfvp-vmhm pac-resolver (npm) Fixed in 5.0.0 Advisory →
- Fix · GHSA-9j49-mfvp-vmhm degenerator (npm) Fixed in 3.0.1 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Advanced Cluster Management for Kubernetes 2 | Affected | No fix yet: Fix deferred |
Not affected: 1 product
- Red Hat Advanced Cluster Management for Kubernetes 2
Timeline
- 2026-10-02 Threatist record created from CVE-2021-23406
- 2026-10-03 Alias added: GHSA-9j49-mfvp-vmhm
References
Patch 3
Sources
- CVE-2021-23406 · CVE Program
- CVE-2021-23406 · NVD
- FIRST EPSS
- GHSA-9j49-mfvp-vmhm · GitHub Advisory Database · CC BY 4.0
- CVE-2021-23406 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences