Cross-site scripting (XSS) in edge.js
Priority LOW 29CWE-843Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
This affects the package edge.js before 5.3.2. A type confusion vulnerability can be used to bypass input sanitization when the input to be rendered is an array (instead of a string or a SafeValue), even if {{ }} are used.
Why it matters now
EPSS 0.00906 60th percentileScored 2026-11-07
Fix Fixed edge.js: 5.3.2edge.js (npm): 5.3.2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | edge.js | before 5.3.2 | 5.3.2 | Patch available | CNA |
| — | edge.js (npm) | before 5.3.2 | 5.3.2 | Patch available | GHSA-55r9-7mf8-m382 |
- edge.js Vendor— Affected before 5.3.2 Fixed in 5.3.2 Patch available CNA
- edge.js (npm) Vendor— Affected before 5.3.2 Fixed in 5.3.2 Patch available GHSA-55r9-7mf8-m382
Remediation
- Fix · CNA edge.js Fixed in 5.3.2
- Fix · GHSA-55r9-7mf8-m382 edge.js (npm) Fixed in 5.3.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2021-23443
- 2026-10-03 Alias added: GHSA-55r9-7mf8-m382
References
Sources
- CVE-2021-23443 · CVE Program
- CVE-2021-23443 · NVD
- FIRST EPSS
- GHSA-55r9-7mf8-m382 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences