Prototype pollution in putil-merge
Priority MEDIUM 45CWE-1321Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.
Summary
This affects the package putil-merge before 3.8.0. The merge() function does not check the values passed into the argument. An attacker can supply a malicious value by adjusting the value to include the constructor property. Note: This vulnerability derives from an incomplete fix in https://security.snyk.io/vuln/SNYK-JS-PUTILMERGE-1317077
Why it matters now
EPSS 0.01266 69th percentileScored 2026-11-07
Fix Fixed putil-merge: 3.8.0putil-merge (npm): 3.8.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | putil-merge | before 3.8.0 | 3.8.0 | Patch available | CNA |
| — | putil-merge (npm) | before 3.8.0 | 3.8.0 | Patch available | GHSA-4g77-cvgw-grvw |
- putil-merge Vendor— Affected before 3.8.0 Fixed in 3.8.0 Patch available CNA
- putil-merge (npm) Vendor— Affected before 3.8.0 Fixed in 3.8.0 Patch available GHSA-4g77-cvgw-grvw
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:putil-merge_project:putil-merge:*:*:*:*:*:*:*:* | before 3.8.0 | Vulnerable | Putil-merge Project |
- cpe:2.3:a:putil-merge_project:putil-merge:*:*:*:*:*:*:*:* Versions before 3.8.0 Vulnerable ·Putil-merge Project
Remediation
- Fix · CNA putil-merge Fixed in 3.8.0
- Fix · GHSA-4g77-cvgw-grvw putil-merge (npm) Fixed in 3.8.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2021-23470
- 2026-10-03 Alias added: GHSA-4g77-cvgw-grvw
References
More Putil-merge Project Putil-merge vulnerabilities
- TI-2021-07959 Prototype pollution in putil-merge CVSS 3.1CRITICAL 9.8
Sources
- CVE-2021-23470 · CVE Program
- CVE-2021-23470 · NVD
- FIRST EPSS
- GHSA-4g77-cvgw-grvw · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences