Read the docs
TI-2021-06447 Aliases CVE-2021-24155GHSA-h635-5m37-x3p5

Backup Guard < 1.6.0 - Authenticated Arbitrary File Upload

Priority HIGH 73CWE-434Published · Updated

Key facts

Attack vector
Network
Privileges required
High
User interaction
None
Attack complexity
Low
Impact type
Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-434.

Summary

The WordPress Backup and Migrate Plugin – Backup Guard WordPress plugin before 1.6.0 did not ensure that the imported files are of the SGBP format and extension, allowing high privilege users (admin+) to upload arbitrary files, including PHP ones, leading to RCE.

Why it matters now

EPSS 0.84112 99th percentileScored 2026-11-07
Public exploit Yes 3 exploit referencesTagged by NVD
Fix Fixed WordPress Backup and Migrate Plugin – Backup Guard (Unknown): 1.6.0

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownWordPress Backup and Migrate Plugin – Backup Guard1.6.0 to before 1.6.01.6.0Patch availableCNA
  • WordPress Backup and Migrate Plugin – Backup Guard VendorUnknown Affected 1.6.0 to before 1.6.0 Fixed in 1.6.0 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:backup-guard:backup_guard:*:*:*:*:*:wordpress:*:*before 1.6.0Vulnerablebackupguard
  • cpe:2.3:a:backup-guard:backup_guard:*:*:*:*:*:wordpress:*:* Versions before 1.6.0 Vulnerable ·backupguard

Remediation

  • Fix · CNA WordPress Backup and Migrate Plugin – Backup Guard (Unknown) Fixed in 1.6.0

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-24155
  2. 2026-10-03 Alias added: GHSA-h635-5m37-x3p5

References

  • TI-2017-13661 The Backup Guard plugin before 1.1.47 for WordPress has multiple XSS issues. CVSS 3.0MEDIUM 6.1
  • TI-2017-07938 Cross-site scripting in BackupGuard CVSS 3.1MEDIUM 6.1

Sources