Related Posts for WordPress < 2.0.4 - Authenticated Reflected Cross-Site Scripting (XSS)
Priority LOW 25CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
Unvalidated input and lack of output encoding within the Related Posts for WordPress plugin before 2.0.4 lead to a Reflected Cross-Site Scripting (XSS) vulnerability within the 'lang' GET parameter while editing a post, triggered when users with the capability of editing posts access a malicious URL.
Why it matters now
EPSS 0.00632 50th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Related Posts for WordPress (Unknown): 2.0.4
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Related Posts for WordPress | 2.0.4 to before 2.0.4 | 2.0.4 | Patch available | CNA |
- Related Posts for WordPress VendorUnknown Affected 2.0.4 to before 2.0.4 Fixed in 2.0.4 Patch available CNA
Remediation
- Fix · CNA Related Posts for WordPress (Unknown) Fixed in 2.0.4
Timeline
- 2026-10-02 Threatist record created from CVE-2021-24180
- 2026-10-03 Alias added: GHSA-6wjh-h2vc-4wfg
- 2026-10-27 EPSS moved to the 50th–90th percentile
References
More Never5 Related Posts vulnerabilities
- TI-2022-03236 Cross-site Scripting (XSS) - Stored in barrykooij/related-posts-for-wp CVSS 3.1MEDIUM 5.4
- TI-2015-07738 The Related Posts plugin before 1.8.2 for WordPress has XSS via add_query_arg() and remove_query_arg(). CVSS 3.0MEDIUM 6.1
- TI-2024-00548 Related Posts for WordPress <= 2.2.1 - Cross-Site Request Forgery CVSS 3.1MEDIUM 5.4
- TI-2021-06769 Related Posts for WordPress <= 2.0.4 - Authenticated Stored XSS & XFS CVSS 3.1MEDIUM 4.8
Sources
- CVE-2021-24180 · CVE Program
- CVE-2021-24180 · NVD
- FIRST EPSS
- GHSA-6wjh-h2vc-4wfg · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences