Tree Sitemap < 2.9 - Arbitrary Plugin Installation/Activation via Low Privilege User
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-285.
Summary
Low privileged users can use the AJAX action 'cp_plugins_do_button_job_later_callback' in the Tree Sitemap WordPress plugin before 2.9, to install any plugin (including a specific version) from the WordPress repository, as well as activate arbitrary plugin from then blog, which helps attackers install vulnerable plugins and could lead to more critical vulnerabilities like RCE.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| wp-buy | Tree Sitemap (Pages, Posts & Categories list) | 2.9 to before 2.9 | 2.9 | Patch available | CNA |
- Tree Sitemap (Pages, Posts & Categories list) Vendorwp-buy Affected 2.9 to before 2.9 Fixed in 2.9 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:sitemap_project:sitemap:*:*:*:*:*:wordpress:*:* | before 2.9 | Vulnerable | Sitemap Project |
- cpe:2.3:a:sitemap_project:sitemap:*:*:*:*:*:wordpress:*:* Versions before 2.9 Vulnerable ·Sitemap Project
Remediation
- Fix · CNA Tree Sitemap (Pages, Posts & Categories list) (wp-buy) Fixed in 2.9
Timeline
- 2026-10-02 Threatist record created from CVE-2021-24192
- 2026-10-03 Alias added: GHSA-qvhh-p8m2-pw7f
References
More wp-buy vulnerabilities
- TI-2022-03943 Login as User or Customer < 3.3 - Unauthenticated Privilege Escalation to Admin CVSS 3.1CRITICAL 9.8
- TI-2024-06199 WP Content Copy Protection & No Right Click (premium) < 15.3 - Open Redirect CVSS 3.1MEDIUM 6.1
- TI-2023-06631 Login as User or Customer <= 3.8 - Admin Account Takeover CVSS 3.1MEDIUM 4.9
- TI-2024-06202 WP Content Copy Protection & No Right Click (premium) <= 15.0 - Admin+ Stored XSS CVSS 3.1MEDIUM 4.8
- TI-2023-28136 WordPress Login as User or Customer plugin <= 3.8 - Unauthenticated Account Takeover vulnerability CVSS 3.1CRITICAL 9.8
- TI-2024-36323 WordPress Limit Login Attempts plugin <= 5.5 - SQL Injection vulnerability CVSS 3.1CRITICAL 9.3
Sources
- CVE-2021-24192 · CVE Program
- CVE-2021-24192 · NVD
- FIRST EPSS
- GHSA-qvhh-p8m2-pw7f · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences