OpenID Connect Generic Client 3.8.0-3.8.1 - Reflected Cross Site Scripting (XSS) via Login Error
Priority LOW 31CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
The OpenID Connect Generic Client WordPress plugin 3.8.0 and 3.8.1 did not sanitise the login error when output back in the login form, leading to a reflected Cross-Site Scripting issue. This issue does not require authentication and can be exploited with the default configuration.
Why it matters now
EPSS 0.01623 76th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed OpenID Connect Generic Client (daggerhart): 3.8.2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| daggerhart | OpenID Connect Generic Client | 3.8.0 and later; 3.8.2 to before 3.8.2 | 3.8.2 | Patch available | CNA |
- OpenID Connect Generic Client Vendordaggerhart Affected 3.8.0 and later; 3.8.2 to before 3.8.2 Fixed in 3.8.2 Patch available CNA
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:daggerhartlab:openid_connect_generic_client:3.8.0:*:*:*:*:wordpress:*:* | 3.8.0 | Vulnerable | Daggerhartlab |
| cpe:2.3:a:daggerhartlab:openid_connect_generic_client:3.8.1:*:*:*:*:wordpress:*:* | 3.8.1 | Vulnerable | Daggerhartlab |
- cpe:2.3:a:daggerhartlab:openid_connect_generic_client:3.8.0:*:*:*:*:wordpress:*:* Versions 3.8.0 Vulnerable ·Daggerhartlab
- cpe:2.3:a:daggerhartlab:openid_connect_generic_client:3.8.1:*:*:*:*:wordpress:*:* Versions 3.8.1 Vulnerable ·Daggerhartlab
Remediation
- Fix · CNA OpenID Connect Generic Client (daggerhart) Fixed in 3.8.2
Timeline
- 2026-10-02 Threatist record created from CVE-2021-24214
- 2026-10-03 Alias added: GHSA-6gp2-g559-39jj
References
More daggerhart vulnerabilities
- TI-2026-12246 Query Wrangler <= 1.5.57 - Authenticated (Subscriber+) Remote Code Execution via 'options' Parameter CVSS 3.1HIGH 8.8
- TI-2025-12550 OpenID Connect Generic Client <= 3.10.0 - Authenticated (Contributor+) Stored Cross-Site Scripting via Shortcode CVSS 3.1MEDIUM 6.4
Sources
- CVE-2021-24214 · CVE Program
- CVE-2021-24214 · NVD
- FIRST EPSS
- GHSA-6gp2-g559-39jj · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences