WorkScout Core < 1.3.4 - Authenticated Stored XSS & XFS
Priority LOW 25CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
The Workscout Core WordPress plugin before 1.3.4, used by the WorkScout Theme did not sanitise the chat messages sent via the workscout_send_message_chat AJAX action, leading to Stored Cross-Site Scripting and Cross-Frame Scripting issues
Why it matters now
EPSS 0.00659 51st percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Workscout Core (PureThemes): 1.3.4WorkScout (PureThemes): 2.0.33
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| purethemes | Workscout Core | 1.3.4 to before 1.3.4 | 1.3.4 | Patch available | CNA |
| purethemes | WorkScout | 2.0.33 to before 2.0.33 | 2.0.33 | Patch available | CNA |
- Workscout Core Vendorpurethemes Affected 1.3.4 to before 1.3.4 Fixed in 1.3.4 Patch available CNA
- WorkScout Vendorpurethemes Affected 2.0.33 to before 2.0.33 Fixed in 2.0.33 Patch available CNA
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:purethemes:workscout:*:*:*:*:*:wordpress:*:* | before 2.0.33 | Vulnerable | purethemes |
| cpe:2.3:a:purethemes:workscout_core:*:*:*:*:*:wordpress:*:* | before 1.3.4 | Vulnerable | purethemes |
- cpe:2.3:a:purethemes:workscout:*:*:*:*:*:wordpress:*:* Versions before 2.0.33 Vulnerable ·purethemes
- cpe:2.3:a:purethemes:workscout_core:*:*:*:*:*:wordpress:*:* Versions before 1.3.4 Vulnerable ·purethemes
Remediation
- Fix · CNA Workscout Core (PureThemes) Fixed in 1.3.4
- Fix · CNA WorkScout (PureThemes) Fixed in 2.0.33
Timeline
- 2026-10-02 Threatist record created from CVE-2021-24246
- 2026-10-03 Alias added: GHSA-2236-w2hm-xc9j
- 2026-10-09 EPSS moved to the 50th–90th percentile
References
Sources
- CVE-2021-24246 · CVE Program
- CVE-2021-24246 · NVD
- FIRST EPSS
- GHSA-2236-w2hm-xc9j · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences