Read the docs
TI-2021-06549 Aliases CVE-2021-24257GHSA-r2jp-926f-m5r3

Premium Addons for Elementor < 4.2.8 - Contributor+ Stored Cross-Site Scripting (XSS)

Priority LOW 25CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.

Summary

The “Premium Addons for Elementor” WordPress Plugin before 4.2.8 has several widgets that are vulnerable to stored Cross-Site Scripting (XSS) by lower-privileged users such as contributors, all via a similar method.

Why it matters now

EPSS 0.0059 48th percentileScored 2026-11-07
Fix Fixed Premium Addons for Elementor (Unknown): 4.2.8

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownPremium Addons for Elementor4.2.8 to before 4.2.84.2.8Patch availableCNA
  • Premium Addons for Elementor VendorUnknown Affected 4.2.8 to before 4.2.8 Fixed in 4.2.8 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:leap13:premium_addons_for_elementor:*:*:*:*:*:wordpress:*:*before 4.2.8Vulnerableleap13
  • cpe:2.3:a:leap13:premium_addons_for_elementor:*:*:*:*:*:wordpress:*:* Versions before 4.2.8 Vulnerable ·leap13

Remediation

  • Fix · CNA Premium Addons for Elementor (Unknown) Fixed in 4.2.8

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-24257
  2. 2026-10-03 Alias added: GHSA-r2jp-926f-m5r3

References

  • TI-2024-37195 WordPress Premium Addons for Elementor plugin <= 4.10.56 - Broken Access Control vulnerability CVSS 3.1HIGH 8.8
  • TI-2025-12935 Missing authorization in leap13 Premium Addons for Elementor – Powerful Elementor… CVSS 3.1MEDIUM 5.3
  • TI-2023-16879 WordPress Premium Addons PRO Plugin <= 2.8.24 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1HIGH 7.1
  • TI-2025-42015 WordPress Premium Addons for Elementor plugin <= 4.11.53 - Sensitive Data Exposure vulnerability CVSS 3.1MEDIUM 5.3
  • TI-2024-05884 Premium Addons for Elementor <= 4.10.36 - Authenticated (Contributor+) Stored Cross-Site Scripting via Countdown Widget CVSS 3.1MEDIUM 6.4
  • TI-2024-00342 Cross-site scripting in leap13 Premium Addons for Elementor – Powerful Elementor… CVSS 3.1MEDIUM 6.4
See all 35 →

Sources