HT Mega - Absolute Addons for Elementor Page Builder < 1.5.7 - Contributor+ Stored XSS
Priority LOW 26CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
The “HT Mega – Absolute Addons for Elementor Page Builder” WordPress Plugin before 1.5.7 has several widgets that are vulnerable to stored Cross-Site Scripting (XSS) by lower-privileged users such as contributors, all via a similar method.
Why it matters now
EPSS 0.00663 51st percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed HT Mega – Absolute Addons for Elementor Page Builder (Unknown): 1.5.7
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | HT Mega – Absolute Addons for Elementor Page Builder | 1.5.7 to before 1.5.7 | 1.5.7 | Patch available | CNA |
- HT Mega – Absolute Addons for Elementor Page Builder VendorUnknown Affected 1.5.7 to before 1.5.7 Fixed in 1.5.7 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:hasthemes:ht_mega:*:*:*:*:free:wordpress:*:* | before 1.5.7 | Vulnerable | devitemsllc |
- cpe:2.3:a:hasthemes:ht_mega:*:*:*:*:free:wordpress:*:* Versions before 1.5.7 Vulnerable ·devitemsllc
Remediation
- Fix · CNA HT Mega – Absolute Addons for Elementor Page Builder (Unknown) Fixed in 1.5.7
Timeline
- 2026-10-02 Threatist record created from CVE-2021-24261
- 2026-10-03 Alias added: GHSA-4vmw-hgp9-m43m
- 2026-10-06 EPSS moved to the 50th–90th percentile
References
More devitemsllc Ht Mega vulnerabilities
- TI-2023-19431 WordPress HT Mega Absolute Addons for Elementor plugin <= 2.2.0 - Unauthenticated Privilege Escalation vulnerability CVSS 3.1CRITICAL 9.8
- TI-2024-01837 HT Mega – Absolute Addons For Elementor <= 2.4.5 - Authenticated (Contributor+) Directory Traversal CVSS 3.1HIGH 8.8
- TI-2023-05708 HT Mega – Absolute Addons For Elementor <= 2.4.6 - Sensitive Information Exposure via purchased_products CVSS 3.1HIGH 7.5
- TI-2024-25940 WordPress HT Mega plugin <= 2.5.7 - JSON Path Traversal vulnerability CVSS 3.1HIGH 8.8
- TI-2023-28181 WordPress HT Mega Plugin <= 2.3.3 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8
- TI-2024-11691 Cross-site scripting in devitemsllc HT Mega Addons for Elementor – Elementor Widgets &… CVSS 3.1MEDIUM 6.4
Sources
- CVE-2021-24261 · CVE Program
- CVE-2021-24261 · NVD
- FIRST EPSS
- GHSA-4vmw-hgp9-m43m · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences