WooLentor - WooCommerce Elementor Addons + Builder < 1.8.6 - Contributor+ Stored XSS
Priority LOW 25CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
The “WooLentor – WooCommerce Elementor Addons + Builder” WordPress Plugin before 1.8.6 has a widget that is vulnerable to stored Cross-Site Scripting (XSS) by lower-privileged users such as contributors, all via a similar method.
Why it matters now
EPSS 0.0059 48th percentileScored 2026-11-07
Fix Fixed WooLentor – WooCommerce Elementor Addons + Builder (Unknown): 1.8.6
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | WooLentor – WooCommerce Elementor Addons + Builder | 1.8.6 to before 1.8.6 | 1.8.6 | Patch available | CNA |
- WooLentor – WooCommerce Elementor Addons + Builder VendorUnknown Affected 1.8.6 to before 1.8.6 Fixed in 1.8.6 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:hasthemes:woolentor_-_woocommerce_elementor_addons_\+_builder:*:*:*:*:*:wordpress:*:* | before 1.8.6 | Vulnerable | devitemsllc |
- cpe:2.3:a:hasthemes:woolentor_-_woocommerce_elementor_addons_\+_builder:*:*:*:*:*:wordpress:*:* Versions before 1.8.6 Vulnerable ·devitemsllc
Remediation
- Fix · CNA WooLentor – WooCommerce Elementor Addons + Builder (Unknown) Fixed in 1.8.6
Timeline
- 2026-10-02 Threatist record created from CVE-2021-24262
- 2026-10-03 Alias added: GHSA-3mmh-h28h-wgxq
References
More devitemsllc Woolentor - Woocommerce Elementor Addons + Builder vulnerabilities
- TI-2022-23376 WordPress WooLentor Plugin <= 2.6.2 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8
- TI-2024-08041 Cross-site scripting in devitemsllc ShopLentor – All-in-One WooCommerce Growth & Store… CVSS 3.1MEDIUM 6.4
- TI-2022-23144 WordPress WooLentor Plugin <= 2.5.1 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1MEDIUM 5.4
Sources
- CVE-2021-24262 · CVE Program
- CVE-2021-24262 · NVD
- FIRST EPSS
- GHSA-3mmh-h28h-wgxq · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences