Read the docs
TI-2021-06561 Aliases CVE-2021-24269GHSA-pjqf-p7cw-pv8c

Sina Extension for Elementor < 3.3.12 - Contributor+ Stored XSS

Priority LOW 25CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.

Summary

The “Sina Extension for Elementor” WordPress Plugin before 3.3.12 has several widgets that are vulnerable to stored Cross-Site Scripting (XSS) by lower-privileged users such as contributors, all via a similar method.

Why it matters now

EPSS 0.0059 48th percentileScored 2026-11-07
Fix Fixed Sina Extension for Elementor (Unknown): 3.3.12

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownSina Extension for Elementor3.3.12 to before 3.3.123.3.12Patch availableCNA
  • Sina Extension for Elementor VendorUnknown Affected 3.3.12 to before 3.3.12 Fixed in 3.3.12 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:sinaextra:sina_extension_for_elementor:*:*:*:*:*:wordpress:*:*before 3.3.12Vulnerableshaonsina
  • cpe:2.3:a:sinaextra:sina_extension_for_elementor:*:*:*:*:*:wordpress:*:* Versions before 3.3.12 Vulnerable ·shaonsina

Remediation

  • Fix · CNA Sina Extension for Elementor (Unknown) Fixed in 3.3.12

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-24269
  2. 2026-10-03 Alias added: GHSA-pjqf-p7cw-pv8c

References

  • TI-2024-22724 WordPress Sina Extension for Elementor plugin <= 3.5.1 - Local File Inclusion vulnerability CVSS 3.1HIGH 8.8
  • TI-2019-11906 The sina-extension-for-elementor plugin before 2.2.1 for WordPress has local file inclusion. CVSS 3.0HIGH 7.5
  • TI-2025-31310 WordPress Sina Extension for Elementor plugin <= 3.6.1 - Cross Site Scripting (XSS) Vulnerability CVSS 3.1HIGH 7.6
  • TI-2025-01306 Cross-site scripting in shaonsina Sina Extension for Elementor CVSS 3.1MEDIUM 6.4
  • TI-2024-19702 WordPress Sina Extension for Elementor plugin <= 3.5.0 - Cross Site Scripting (XSS) vulnerability CVSS 3.1MEDIUM 6.5
  • TI-2024-04884 Cross-site scripting in shaonsina Sina Extension for Elementor CVSS 3.1MEDIUM 6.4
See all 13 →

Sources