DethemeKit For Elementor < 1.5.5.5 - Contributor+ Stored XSS
Priority LOW 25CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
The “DeTheme Kit for Elementor” WordPress Plugin before 1.5.5.5 has a widget that is vulnerable to stored Cross-Site Scripting (XSS) by lower-privileged users such as contributors, all via a similar method.
Why it matters now
EPSS 0.0059 48th percentileScored 2026-11-07
Fix Fixed DethemeKit For Elementor (Unknown): 1.5.5.5
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | DethemeKit For Elementor | 1.5.5.5 to before 1.5.5.5 | 1.5.5.5 | Patch available | CNA |
- DethemeKit For Elementor VendorUnknown Affected 1.5.5.5 to before 1.5.5.5 Fixed in 1.5.5.5 Patch available CNA
Remediation
- Fix · CNA DethemeKit For Elementor (Unknown) Fixed in 1.5.5.5
Timeline
- 2026-10-02 Threatist record created from CVE-2021-24270
- 2026-10-03 Alias added: GHSA-f37x-2cx7-rh6g
References
More Dethemekit For Elementor vulnerabilities
- TI-2024-04076 DethemeKit For Elementor <= 2.1.3 - Authenticated (Contributor+) Stored Cross-Site Scripting via Multiple Widgets CVSS 3.1MEDIUM 6.4
- TI-2024-21395 WordPress DethemeKit For Elementor plugin <= 2.0.2 - Cross Site Scripting (XSS) vulnerability CVSS 3.1MEDIUM 6.5
- TI-2025-19688 WordPress DethemeKit For Elementor plugin <= 2.1.8 - Cross Site Scripting (XSS) vulnerability CVSS 3.1MEDIUM 6.5
- TI-2025-01313 DethemeKit for Elementor <= 2.1.9 - Authenticated (Contributor+) Stored Cross-Site Scripting CVSS 3.1MEDIUM 6.4
- TI-2024-31911 WordPress DethemeKit For Elementor plugin <= 2.1.7 - Cross Site Scripting (XSS) vulnerability CVSS 3.1MEDIUM 6.5
- TI-2024-22877 WordPress DethemeKit For Elementor plugin <= 2.1.2 - Cross Site Scripting (XSS) vulnerability CVSS 3.1MEDIUM 6.5
Sources
- CVE-2021-24270 · CVE Program
- CVE-2021-24270 · NVD
- FIRST EPSS
- GHSA-f37x-2cx7-rh6g · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences