Clever Addons for Elementor < 2.1.0 - Contributor+ Stored XSS
Priority LOW 25CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
The “Clever Addons for Elementor” WordPress Plugin before 2.1.0 has several widgets that are vulnerable to stored Cross-Site Scripting (XSS) by lower-privileged users such as contributors, all via a similar method.
Why it matters now
EPSS 0.0059 48th percentileScored 2026-11-07
Fix Fixed Clever Addons for Elementor (CleverSoft): 2.1.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| CleverSoft | Clever Addons for Elementor | 2.1.0 to before 2.1.0 | 2.1.0 | Patch available | CNA |
- Clever Addons for Elementor VendorCleverSoft Affected 2.1.0 to before 2.1.0 Fixed in 2.1.0 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:cleversoft:clever_addons_for_elementor:*:*:*:*:*:wordpress:*:* | before 2.1.0 | Vulnerable | CleverSoft |
- cpe:2.3:a:cleversoft:clever_addons_for_elementor:*:*:*:*:*:wordpress:*:* Versions before 2.1.0 Vulnerable ·CleverSoft
Remediation
- Fix · CNA Clever Addons for Elementor (CleverSoft) Fixed in 2.1.0
Timeline
- 2026-10-02 Threatist record created from CVE-2021-24273
- 2026-10-03 Alias added: GHSA-36g2-h6pw-2fpg
References
More CleverSoft Clever Addons For Elementor vulnerabilities
- TI-2024-34495 WordPress Clever Addons for Elementor plugin <= 2.2.1 - Cross Site Scripting (XSS) vulnerability CVSS 3.1MEDIUM 6.5
- TI-2024-02185 Cross-site scripting in zootemplate Clever Addons for Elementor CVSS 3.1MEDIUM 6.4
- TI-2024-28976 WordPress Clever Addons for Elementor plugin <= 2.2.0 - Cross Site Scripting (XSS) vulnerability CVSS 3.1MEDIUM 5.9
Sources
- CVE-2021-24273 · CVE Program
- CVE-2021-24273 · NVD
- FIRST EPSS
- GHSA-36g2-h6pw-2fpg · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences