Contact Form by Supsystic < 1.7.15 - Reflected Cross-Site scripting (XSS)
Priority MEDIUM 44CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
The Contact Form by Supsystic WordPress plugin before 1.7.15 did not sanitise the tab parameter of its options page before outputting it in an attribute, leading to a reflected Cross-Site Scripting issue
Why it matters now
EPSS 0.16044 96th percentileScored 2026-11-07
Public exploit Yes 2 exploit referencesTagged by NVD
Fix Fixed Contact Form by Supsystic (Supsystic): 1.7.15
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
Remediation
- Fix · CNA Contact Form by Supsystic (Supsystic) Fixed in 1.7.15
Timeline
- 2026-10-02 Threatist record created from CVE-2021-24276
- 2026-10-03 Alias added: GHSA-p8j5-xg8p-f3xm
References
More Supsystic Contact Form vulnerabilities
- TI-2023-24116 WordPress Contact Form by Supsystic Plugin <= 1.7.27 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8
- TI-2023-02369 Contact Form by Supsystic <= 1.7.24 - Cross-Site Request Forgery via AJAX action CVSS 3.1HIGH 8.8
Sources
- CVE-2021-24276 · CVE Program
- CVE-2021-24276 · NVD
- FIRST EPSS
- GHSA-p8j5-xg8p-f3xm · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences