Read the docs
TI-2021-06622 Aliases CVE-2021-24330GHSA-jpx9-hmgp-grj6

Funnel Builder by CartFlows < 1.6.13 - Authenticated Stored XSS via FB Pixel ID and Google Analytics ID

Priority LOW 23CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
High
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.

Summary

The Funnel Builder by CartFlows – Create High Converting Sales Funnels For WordPress plugin before 1.6.13 did not sanitise its facebook_pixel_id and google_analytics_id settings, allowing high privilege users to set XSS payload in them, which will either be executed on pages generated by the plugin, or the whole website depending on the settings used.

Why it matters now

EPSS 0.00652 51st percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Funnel Builder by CartFlows – Create High Converting Sales Funnels For WordPress (Unknown): 1.6.13

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownFunnel Builder by CartFlows – Create High Converting Sales Funnels For WordPress1.6.13 to before 1.6.131.6.13Patch availableCNA
  • Funnel Builder by CartFlows – Create High Converting Sales Funnels For WordPress VendorUnknown Affected 1.6.13 to before 1.6.13 Fixed in 1.6.13 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:cartflows:cartflows:*:*:*:*:*:wordpress:*:*before 1.6.13VulnerableCartFlows
  • cpe:2.3:a:cartflows:cartflows:*:*:*:*:*:wordpress:*:* Versions before 1.6.13 Vulnerable ·CartFlows

Remediation

  • Fix · CNA Funnel Builder by CartFlows – Create High Converting Sales Funnels For WordPress (Unknown) Fixed in 1.6.13

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-24330
  2. 2026-10-03 Alias added: GHSA-jpx9-hmgp-grj6
  3. 2026-10-14 EPSS moved to the 50th–90th percentile

References

  • TI-2023-18501 WordPress CartFlows Pro Plugin <= 1.11.11 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1HIGH 7.1
  • TI-2019-15254 Funnel Builder <= 1.3.0 - Arbitrary Plugin Activation CVSS 3.1MEDIUM 5.4
  • TI-2020-18905 Cross-site request forgery in Brainstorm Force CartFlows – Funnel Builder & Checkout… CVSS 3.1MEDIUM 4.3

Sources