iFlyChat – WordPress Chat < 4.7.0 - Admin+ Stored Cross-Site Scripting (XSS)
Priority LOW 23CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
The iFlyChat WordPress plugin before 4.7.0 does not sanitise its APP ID setting before outputting it back in the page, leading to an authenticated Stored Cross-Site Scripting issue
Why it matters now
EPSS 0.00613 49th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed iFlyChat – WordPress Chat (Unknown): 4.7.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | iFlyChat – WordPress Chat | 4.7.0 to before 4.7.0 | 4.7.0 | Patch available | CNA |
- iFlyChat – WordPress Chat VendorUnknown Affected 4.7.0 to before 4.7.0 Fixed in 4.7.0 Patch available CNA
Remediation
- Fix · CNA iFlyChat – WordPress Chat (Unknown) Fixed in 4.7.0
Timeline
- 2026-10-02 Threatist record created from CVE-2021-24343
- 2026-10-03 Alias added: GHSA-3gj8-rw59-4xgx
References
More Iflychat vulnerabilities
- TI-2024-20497 WordPress iFlyChat plugin <= 4.7.2 - Cross Site Scripting (XSS) vulnerability CVSS 3.1MEDIUM 6.5
Sources
- CVE-2021-24343 · CVE Program
- CVE-2021-24343 · NVD
- FIRST EPSS
- GHSA-3gj8-rw59-4xgx · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences