FooGallery < 2.0.35 - Authenticated Stored Cross-Site Scripting
Priority LOW 25CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
In the Best Image Gallery & Responsive Photo Gallery – FooGallery WordPress plugin before 2.0.35, the Custom CSS field of each gallery is not properly sanitised or validated before being being output in the page where the gallery is embed, leading to a stored Cross-Site Scripting issue.
Why it matters now
EPSS 0.00624 50th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Best Image Gallery & Responsive Photo Gallery – FooGallery (FooPlugins): 2.0.35
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| fooplugins | Best Image Gallery & Responsive Photo Gallery – FooGallery | 2.0.35 to before 2.0.35 | 2.0.35 | Patch available | CNA |
- Best Image Gallery & Responsive Photo Gallery – FooGallery Vendorfooplugins Affected 2.0.35 to before 2.0.35 Fixed in 2.0.35 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:fooplugins:foogallery:*:*:*:*:*:wordpress:*:* | before 2.0.35 | Vulnerable | fooplugins |
- cpe:2.3:a:fooplugins:foogallery:*:*:*:*:*:wordpress:*:* Versions before 2.0.35 Vulnerable ·fooplugins
Remediation
- Fix · CNA Best Image Gallery & Responsive Photo Gallery – FooGallery (FooPlugins) Fixed in 2.0.35
Timeline
- 2026-10-02 Threatist record created from CVE-2021-24357
- 2026-10-03 Alias added: GHSA-2q7g-6q23-mgp7
- 2026-11-04 EPSS moved to the 50th–90th percentile
References
More fooplugins Foogallery vulnerabilities
- TI-2023-23759 WordPress FooGallery Plugin <= 2.2.44 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8
- TI-2023-13819 WordPress FooGallery Plugin <= 2.2.35 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1HIGH 7.1
- TI-2023-06350 Best WordPress Gallery Plugin – FooGallery <= 2.4.16 - Authenticated (Contributor+) Directory Traversal CVSS 3.1HIGH 7.7
- TI-2024-11241 Cross-site scripting in fooplugins Gallery by FooGallery CVSS 3.1MEDIUM 6.4
- TI-2023-23770 WordPress FooGallery Plugin <= 2.2.44 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1HIGH 7.1
- TI-2024-01972 FooGallery <= 2.4.15 - Authenticated (Contributor+) Stored Cross-Site Scripting via Gallery Custom URL CVSS 3.1MEDIUM 6.4
Sources
- CVE-2021-24357 · CVE Program
- CVE-2021-24357 · NVD
- FIRST EPSS
- GHSA-2q7g-6q23-mgp7 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences