Read the docs
TI-2021-06661 Aliases CVE-2021-24369GHSA-83pg-f5q7-v37g

GetPaid < 2.3.4 - Authenticated Stored XSS

Priority LOW 25CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.

Summary

In the GetPaid WordPress plugin before 2.3.4, users with the contributor role and above can create a new Payment Form, however the Label and Help Text input fields were not getting sanitized properly. So it was possible to inject malicious content such as img tags, leading to a Stored Cross-Site Scripting issue which is triggered when the form will be edited, for example when an admin reviews it and could lead to privilege escalation.

Why it matters now

EPSS 0.00624 50th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed WordPress Payments Plugin | GetPaid (AyeCode Ltd): 2.3.4

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
AyeCode LtdWordPress Payments Plugin | GetPaid2.3.4 to before 2.3.42.3.4Patch availableCNA
  • WordPress Payments Plugin | GetPaid VendorAyeCode Ltd Affected 2.3.4 to before 2.3.4 Fixed in 2.3.4 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:ayecode:getpaid:*:*:*:*:*:wordpress:*:*before 2.3.4VulnerableAyeCode Ltd
  • cpe:2.3:a:ayecode:getpaid:*:*:*:*:*:wordpress:*:* Versions before 2.3.4 Vulnerable ·AyeCode Ltd

Remediation

  • Fix · CNA WordPress Payments Plugin | GetPaid (AyeCode Ltd) Fixed in 2.3.4

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-24369
  2. 2026-10-03 Alias added: GHSA-83pg-f5q7-v37g
  3. 2026-11-04 EPSS moved to the 50th–90th percentile

References

  • TI-2024-29562 WordPress GetPaid plugin <= 2.8.11 - Broken Access Control vulnerability CVSS 3.1HIGH 8.8

Sources