Prismatic < 2.8 - Contributor+ Stored XSS
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
The Prismatic WordPress plugin before 2.8 does not sanitise or validate some of its shortcode parameters, allowing users with a role as low as Contributor to set Cross-Site payload in them. A post made by a contributor would still have to be approved by an admin to have the XSS trigger able in the frontend, however, higher privilege users, such as editor could exploit this without the need of approval, and even when the blog disallows the unfiltered_html capability.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
Remediation
- Fix · CNA Prismatic (Jeff Starr) Fixed in 2.8
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Jeff Starr Prismatic 2.8
2 records Highest priority Priority LOW 2 LOW
Other records, highest priority first
- TI-2021-06701 Prismatic < 2.8 - Reflected Cross-Site Scripting (XSS)Priority LOW 31
Timeline
- 2026-10-02 Threatist record created from CVE-2021-24408
- 2026-10-03 Alias added: GHSA-vc6f-wccw-cfjq
- 2026-11-04 EPSS moved to the 50th–90th percentile
References
More specialk Prismatic vulnerabilities
- TI-2021-06701 Prismatic < 2.8 - Reflected Cross-Site Scripting (XSS) CVSS 3.1MEDIUM 6.1
Sources
- CVE-2021-24408 · CVE Program
- CVE-2021-24408 · NVD
- FIRST EPSS
- GHSA-vc6f-wccw-cfjq · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences