Leaflet Map < 3.0.0 - Arbitrary Settings Update via CSRF Leading to Stored XSS
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Tampering, Cross-site scripting
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-352 and CWE-79.
Summary
The Leaflet Map WordPress plugin before 3.0.0 does not verify the CSRF nonce when saving its settings, which allows attackers to make a logged in admin update the settings via a Cross-Site Request Forgery attack. This could lead to Cross-Site Scripting issues by either changing the URL of the JavaScript library being used, or using malicious attributions which will be executed in all page with an embed map from the plugin
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Leaflet Map | 3.0.0 to before 3.0.0 | 3.0.0 | Patch available | CNA |
- Leaflet Map VendorUnknown Affected 3.0.0 to before 3.0.0 Fixed in 3.0.0 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:leaflet_map_project:leaflet_map:*:*:*:*:*:wordpress:*:* | before 3.0.0 | Vulnerable | Leaflet Map Project |
- cpe:2.3:a:leaflet_map_project:leaflet_map:*:*:*:*:*:wordpress:*:* Versions before 3.0.0 Vulnerable ·Leaflet Map Project
Remediation
- Fix · CNA Leaflet Map (Unknown) Fixed in 3.0.0
Timeline
- 2026-10-02 Threatist record created from CVE-2021-24467
- 2026-10-03 Alias added: GHSA-xqqw-c6r3-8gjc
References
Sources
- CVE-2021-24467 · CVE Program
- CVE-2021-24467 · NVD
- FIRST EPSS
- GHSA-xqqw-c6r3-8gjc · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences