Leaflet Map < 3.0.0 - Contributor+ Stored XSS
Priority LOW 25CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
The Leaflet Map WordPress plugin before 3.0.0 does not escape some shortcode attributes before they are used in JavaScript code or HTML, which could allow users with a role as low as Contributors to exploit stored XSS issues
Why it matters now
EPSS 0.00624 50th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Leaflet Map (Unknown): 3.0.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Leaflet Map | 3.0.0 to before 3.0.0 | 3.0.0 | Patch available | CNA |
- Leaflet Map VendorUnknown Affected 3.0.0 to before 3.0.0 Fixed in 3.0.0 Patch available CNA
Remediation
- Fix · CNA Leaflet Map (Unknown) Fixed in 3.0.0
Timeline
- 2026-10-02 Threatist record created from CVE-2021-24468
- 2026-10-03 Alias added: GHSA-9px2-pxx2-vq3x
- 2026-11-04 EPSS moved to the 50th–90th percentile
References
More bozdoz Leaflet Map vulnerabilities
- TI-2023-04650 Leaflet Map <= 3.3.0 - Authenticated (Contributor+) Stored Cross-Site Scripting via Shortcode CVSS 3.1MEDIUM 6.4
Sources
- CVE-2021-24468 · CVE Program
- CVE-2021-24468 · NVD
- FIRST EPSS
- GHSA-9px2-pxx2-vq3x · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences