Forms < 1.12.3 - Authenticated Stored Cross-Site Scripting (XSS)
Priority LOW 25CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
The Forms WordPress plugin before 1.12.3 did not sanitise its input fields, leading to Stored Cross-Site scripting issues. The plugin was vulnerable to an Authenticated Stored Cross-Site Scripting (XSS) vulnerability within the Forms "Add new" field.
Why it matters now
EPSS 0.0062 49th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Forms (Unknown): 1.12.3
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Forms | 1.12.3 to before 1.12.3 | 1.12.3 | Patch available | CNA |
- Forms VendorUnknown Affected 1.12.3 to before 1.12.3 Fixed in 1.12.3 Patch available CNA
Remediation
- Fix · CNA Forms (Unknown) Fixed in 1.12.3
Timeline
- 2026-10-02 Threatist record created from CVE-2021-24505
- 2026-10-03 Alias added: GHSA-chv5-257q-w5jx
References
Sources
- CVE-2021-24505 · CVE Program
- CVE-2021-24505 · NVD
- FIRST EPSS
- GHSA-chv5-257q-w5jx · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences