Read the docs
TI-2021-06810 Aliases CVE-2021-24523GHSA-68vv-fjgv-68v7

Daily Prayer Time < 2021.08.10 - Authenticated Stored XSS

Priority LOW 25CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.

Summary

The Daily Prayer Time WordPress plugin before 2021.08.10 does not sanitise or escape some of its settings before outputting them in the page, leading to Authenticated Stored Cross-Site Scripting issues.

Why it matters now

EPSS 0.0062 49th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Daily Prayer Time (Unknown): 2021.08.10

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownDaily Prayer Time2021.08.10 to before 2021.08.102021.08.10Patch availableCNA
  • Daily Prayer Time VendorUnknown Affected 2021.08.10 to before 2021.08.10 Fixed in 2021.08.10 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:mmrs151:daily_prayer_time:*:*:*:*:*:wordpress:*:*before 2021.08.10Vulnerablemmrs151
  • cpe:2.3:a:mmrs151:daily_prayer_time:*:*:*:*:*:wordpress:*:* Versions before 2021.08.10 Vulnerable ·mmrs151

Remediation

  • Fix · CNA Daily Prayer Time (Unknown) Fixed in 2021.08.10

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-24523
  2. 2026-10-03 Alias added: GHSA-68vv-fjgv-68v7

References

  • TI-2024-07997 Daily Prayer Time <= 2024.08.26 - Authenticated (Contributor+) SQL Injection CVSS 3.1CRITICAL 9.9
  • TI-2023-12342 WordPress Daily Prayer Time Plugin <= 2023.03.08 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8
  • TI-2023-25925 WordPress Daily Prayer Time Plugin <= 2023.10.13 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 6.5
  • TI-2023-12341 WordPress Daily Prayer Time Plugin <= 2023.05.04 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 6.5

Sources