Read the docs
TI-2021-06818 Aliases CVE-2021-24531GHSA-pgq5-cwpc-m697

Charitable – Donation Plugin < 1.6.51 - Authenticated Stored Cross-Site Scripting (XSS)

Priority LOW 25CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.

Summary

The Charitable – Donation Plugin WordPress plugin before 1.6.51 is affected by an authenticated stored cross-site scripting vulnerability which was found in the add donation feature.

Why it matters now

EPSS 0.00576 47th percentileScored 2026-11-07
Fix Fixed Charitable – Donation Plugin (Unknown): 1.6.51

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownCharitable – Donation Plugin1.6.51 to before 1.6.511.6.51Patch availableCNA
  • Charitable – Donation Plugin VendorUnknown Affected 1.6.51 to before 1.6.51 Fixed in 1.6.51 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:wpcharitable:charitable:*:*:*:*:*:wordpress:*:*before 1.6.51VulnerableWpcharitable
  • cpe:2.3:a:wpcharitable:charitable:*:*:*:*:*:wordpress:*:* Versions before 1.6.51 Vulnerable ·Wpcharitable

Remediation

  • Fix · CNA Charitable – Donation Plugin (Unknown) Fixed in 1.6.51

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-24531
  2. 2026-10-03 Alias added: GHSA-pgq5-cwpc-m697

References

  • TI-2023-04067 Donation Forms by Charitable <= 1.7.0.12 - Unauthenticated Privilege Escalation CVSS 3.1CRITICAL 9.8
  • TI-2024-08157 Authorization bypass in smub Charitable – Donation Plugin for WordPress – Fundraising… CVSS 3.1CRITICAL 9.8
  • TI-2018-14973 The charitable plugin before 1.5.14 for WordPress has unauthorized access to user and donation details. CVSS 3.1HIGH 7.5
  • TI-2022-23518 WordPress Charitable Plugin <= 1.7.0.10 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1HIGH 7.1
  • TI-2023-25924 WordPress Charitable Plugin <= 1.7.0.13 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 6.5

Sources