Wonder PDF Embed < 1.7 - Contributor+ Stored XSS
Priority LOW 25CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
The Wonder PDF Embed WordPress plugin before 1.7 does not escape parameters of its wonderplugin_pdf shortcode, which could allow users with a role as low as Contributor to perform Stored XSS attacks.
Why it matters now
EPSS 0.00624 50th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Wonder PDF Embed (Unknown): 1.7
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Wonder PDF Embed | 1.7 to before 1.7 | 1.7 | Patch available | CNA |
- Wonder PDF Embed VendorUnknown Affected 1.7 to before 1.7 Fixed in 1.7 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:wonderplugin:wonder_pdf_embed:*:*:*:*:*:wordpress:*:* | before 1.7 | Vulnerable | wonderplugin |
- cpe:2.3:a:wonderplugin:wonder_pdf_embed:*:*:*:*:*:wordpress:*:* Versions before 1.7 Vulnerable ·wonderplugin
Remediation
- Fix · CNA Wonder PDF Embed (Unknown) Fixed in 1.7
Timeline
- 2026-10-02 Threatist record created from CVE-2021-24541
- 2026-10-03 Alias added: GHSA-43h7-jcr7-fh3r
- 2026-11-04 EPSS moved to the 50th–90th percentile
References
Sources
- CVE-2021-24541 · CVE Program
- CVE-2021-24541 · NVD
- FIRST EPSS
- GHSA-43h7-jcr7-fh3r · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences